GrantLui
Contributor
Contributor

Problems in creating virtual disk from the command line

Jump to solution

Hi there,

I have problems in creating a vmdk using the command line method, I'm quite sure my command format syntax is correct but I keep getting the irritating message "Extra arguments at the end of the command line."

Target vmdk file name without bracket:

vmkfstools -c 73g –d zeroedthick sample.1.vmdk

Extra arguments at the end of the command line.

Target vmdk file name with 'sample.1.vmdk' bracket:

vmkfstools -c 73g –d zeroedthick 'sample.1.vmdk'

Extra arguments at the end of the command line.

Target vmdk file name with "sample.1.vmdk" bracket:

vmkfstools -c 73g –d zeroedthick "sample.1.vmdk"

Extra arguments at the end of the command line.

So basically I really have no idea what went wrong, target storage is a shared storage managed by vcenter

Thanks

Skynet Corporation Limited
0 Kudos
1 Solution

Accepted Solutions
continuum
Immortal
Immortal

Do you use those commands in a script ?
I would expect to see the errors you get when you use Windows notepad and then upload them to ESXi, chmod  to 755 and then execute it.
The commands itself are ok and should work.
If you upload a script you can identify bad line endings by viewing the script by doubleclicking it in WinSCP

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"

View solution in original post

0 Kudos
4 Replies
continuum
Immortal
Immortal

Do you use those commands in a script ?
I would expect to see the errors you get when you use Windows notepad and then upload them to ESXi, chmod  to 755 and then execute it.
The commands itself are ok and should work.
If you upload a script you can identify bad line endings by viewing the script by doubleclicking it in WinSCP

Do you need support with a recovery problem ? - send a message via skype "sanbarrow"

View solution in original post

0 Kudos
a_p_
Leadership
Leadership

vmkfstools -c 73g –d zeroedthick sample.1.vmdk

It looks like the command line was created in Word or another application like this which has "autocorrection" enabled.

Please take a closer look at the highlighted dash!


André

0 Kudos
GrantLui
Contributor
Contributor

Thanks, you are correct, for some reason the character has some difference from typing it in the console directly rather than copy and paste from notepad Smiley Sad

Skynet Corporation Limited
0 Kudos
GrantLui
Contributor
Contributor

Thanks for the suggestion, you are correct!

Skynet Corporation Limited
0 Kudos