bheusmann
Contributor
Contributor

MSA1000 Configuration

Ok, I'll try and make this a quick post, I have tons of information on servers, setup, etc. that I can provide if needed, and I'm trying to configure. But, I've got an MSA1000 with dual channel controllers and dual SAN 2/8 switches in an active/passive configuration and an MSA30 shelf connected to the MSA1000. I'm trying to to configure the MSA1000 to be the backend SAN to my vsphere 4.1 / ESX 3.5 setup (I know vshpere might not be supported, but I know I've seen configurations with it running). I have 3 DL380 G4 severs and an DL580 G2 server. I've got the one DL380 G4 connected to each SAN via 2 single HBA's in the server. I don't' have the console cable to connect to the MSA so I'm not sure how to proceed in configuring the volumes and LUN's on the MSA. When the ACU is opened in Windows, I can access the controller, but there's not much configuration options. The SCU version I am using is 8.6.70.

I noticed a section for SSP. After configuring any Logical drives, is this where I would creat "LUN's" so-to-speak for the vmware server to access??? If this is the case, am I able to access the MSA to configure the array/LUN to "Linux".  Any help would be appreciated. I can provide additional details if needed, I just wanted to get some quick info down.

Additionally in the Windows ACU, I can only create a logical drive of 2TB. I have 3.3TB available in the array. Is this a limitation of windows or the MSA1000? If done through the CLI, would a logical drive greater than 2TB be able to be created? And I'm sure I have more questions to follow. Thanks for any help.

-Bryan

0 Kudos
13 Replies
MauroBonder
Leadership
Leadership

http://kb.vmware.com/kb/1003565

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado
0 Kudos
bheusmann
Contributor
Contributor

Thanks for the link. I have read that, unfortunately I haven't gotten vSphere installed and setup on the DL380 G4 as of yet. I was hoping to get the configuration of the MSA done and available to be accessed via the vSphere host. Any other helpful hints? I hope I can configure it without the Console Cable that I am without. I've got the SAN Switch connected to my Cisco 3750G switch, but I'm not sure if I will be able to change the assigned default IP without the console cable.

-Bryan Heusmann

0 Kudos
MauroBonder
Leadership
Leadership

I could not understand your problem may still try to objectively explain more please.
Your storage is iSCSI or FC?

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado
0 Kudos
bheusmann
Contributor
Contributor

Thanks..I probably should have typed so fast and jumbled everything together. Let's start with first and foremost issue: MSA1000 setup for the vSphere host.

I don't have a console cable for the MSA1000, so total configuration might not be possible, I'm not 100% sure. I have 2 single HBA's in a DL380 server connected to each 2/8 SAN controller in the MSA1000, which is configured default as active/passive. The DL380 has 2008 installed on it currently so I could access the HP Array Configuration Utility. I've created an array of 25 disks, 3.3TB in total, and created 2 logical drives of 500GB each. I enabled Access Control (SSP) on each HBA controller to each 500GB logical drive. This is as far as I've gotten. I'm going to install vSphere 4.1 on the DL380, using the internal SCSI disks of the server for the installation. At this point, am I setup so that the vSphere host can access the SAN LUN or SSP setup to the HBA? Am I able to access and configure any part ofthe MSA1000 like IP address, and specifics for ESX without use of the console cable?

-Bryan Heusmann

0 Kudos
MauroBonder
Leadership
Leadership

OK. You have created the volumes configured zone on the switch, but if you do not have access to the MSA1000 Console, as will assign the LUNS to the Hosts accessing VMware?! You need to access the Storage and "tie" to the Luns VMware Hosts. From the VMware API exists that integrate with Storage, but this API is diponibilizada by the manufacturer of Storage.

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado
habibalby
Hot Shot
Hot Shot

boot the server with the h.p smart start cd then u will see the msa array config, from there create ur volume and from the ssp assgin ur lun 2 the servers also make sure u select linux profile.

or connect windows server 2 the msa  2 create the luns & assgin them.

Best Regards, Hussain Al Sayed Consider awarding points for "correct" or "helpful".
bheusmann
Contributor
Contributor

What version ofthe SmartStart would you reccomend i use? I think I tried this and the server didn't respond well, it may have been a bad burn though.  I can't access the MSA console, is there any other way to access the CLI to the MSA from the windows server? I can open the HP ACU CLI but I'm not sure if it's able to access the MSA via the HBA's installed. Thanks.

-Bryan Heusmann

0 Kudos
habibalby
Hot Shot
Hot Shot

U Can usE THE LATEST VERSION OR OLDER ONE. CLI WONT BE ABLE WITHOUT THE CONSOLE CABLE.

ANY SERVER IF ITS CONNECTED TO THE MSA VIA FC CABLE WILL SEE THE MSA ARRAY CONTROLER.

Best Regards, Hussain Al Sayed Consider awarding points for "correct" or "helpful".
0 Kudos
bheusmann
Contributor
Contributor

I was afraid of that. Looks like I'll have to scope out a cable on eBay. Ok, I have SS CD 8.50 I will boot up and give that a try. Thanks for the assistance and I will report back with results and if further help is needed.

-Bryan

0 Kudos
bheusmann
Contributor
Contributor

Ok, I booted the system to the SS 8.50 CD...I had to midify the xorg.conf file because apparently the Depth is not set to 24 instead of 16 in previous versions and my server didn't like it. So a little mod, and re-running the the init scripts loaded the SmartStart.

Now delima, when opening the ACU from the SS only the Integrated 6i controller is seen, not the HBA's connected to the MSA. PCI device diagnostics shows the HBA's as PCI-X 1000 Gigabit Controllers, but for some reason I can't see the MSA. Is using this ACU the same as using it if I were to install the Proliant Support Pack on a Windows based system? Booting the server (which currently has Server 2008 installed) I can access the ACU and the MSA. What differences are there between this and the SS ACU? Any? As said above, I have created an array and 2 logical 500GB drives on the MSA and assigned the SSP to each controller in the server to it's respected 500GB logical drive and named the Controllers Linux. Is this sufficient for moving forward with installing vSphere 4.1 and then connecting the SAN? Thanks.

-Bryan

0 Kudos
bheusmann
Contributor
Contributor

Ok, vSphere installed sucesfully however, there is no reference to the Emulex HBA's I have installed. I think these controllers are on the bottom of the list, I'm ordering a console cable as well as some QLogic HBA's for these servers. Hopefully that will get me on the right track.

-Bryan

0 Kudos
jof
Enthusiast
Enthusiast

Hi Bryan,

As mentioned earlier, any sevrer connected to the MSA via FC cable should see the controller and allow you configure the disks. Once you have the logical drives configured on the MSA this should be enough configuration for ESX to see and use these volumes (on another point I have seen an issue in the past where SSP had to turned off for ESX to see the storage but this was with older versions of ESX\MSA, so it may not apply)

You can also configure management IP addresses for both fiber switches using the console port on each of them,  allowing the configuration of zones on the fiber switches.

The management cable for the MSA itself is an RJ45Z cable but to be honest if you have the logical drives set up already you should not need this for the moment.

As for your initial question on your LUN sizes, there is a 2TB limit in ESX anyway but you can use extents to increase this to 64TB

0 Kudos
habibalby
Hot Shot
Hot Shot

Hello,

This is the only configuration required in order to present the LUNs to the servers, nothing else needed. Once you presented the LUNs, just do a rescan on the ESX servers and you will see the LUNs appearing in the vmhba1 and vmhba2.

the console cable will require you to configure an ip address to configure all the logical drives, zoning and thier profile via CLI. Honestly, you can't do much with the console cable, doing eveything from the ACU is more than enough for the MSA.

I have configured many MSAs in the past and I'm talking from an experiance. Don't waste money for the Console cable.

Thanks,

Best Regards, Hussain Al Sayed Consider awarding points for "correct" or "helpful".
0 Kudos