JeanDefreank
Contributor
Contributor

Error trying to add SCSI datastore to my ESX

Jump to solution

Hi Guys,

Am new here, my name is Jean Defrank and I would like to know why is it the am getting this error message?

I have four ESX servers 4, running on a cluster, I was able to add the new datastore to three of them, but the last ESX (Number 4) server is giving me this error message.

Am going nats trying to find a solution for this issue... but nothing so far. What can I do?

Thanks in advance.

Add SCSI static SCSI target
diabovm04.dia.state.ma.us
Error during the configuration of the host: Add Static target failure on HBA vmhba35, Target
10.10.1.5:3260:iqn.2001-05.c-
om.equallogic:0-8a0906-a8d08-
4404-01bcf0c92894ddbb-docu-
ment-management - No Such
StaticTarget found: iqn.2001-05
.com.equallogic:0-8a0906-a8d-
084404-01bcf0c92894ddbb-do-
cument-management :: 10.10.1
.5:3260
DOMAIN\JDefrank
DIABOVCENTER01
5/24/2011 10:28:24 AM

0 Kudos
1 Solution

Accepted Solutions
mlubinski
Expert
Expert

login with console or ssh to this esx4 and do following: vmkping 10.10.1.5

paste here output.

also what's real issue, because first you said about adding lun, now you say about removing lun, so i am confused a bit...

[I]If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points[/I]

View solution in original post

0 Kudos
7 Replies
vmroyale
Immortal
Immortal

Hello and welcome to the forums.

Note: This discussion was moved from the Technical Resources community to the  VMware vSphere Storage community.

Is your setup the same for all ESX hosts, and are the settings the same for each host in the EQ?

Good Luck!

Brian Atkinson | vExpert | VMTN Moderator | Author of "VCP5-DCV VMware Certified Professional-Data Center Virtualization on vSphere 5.5 Study Guide: VCP-550" | @vmroyale | http://vmroyale.com
0 Kudos
JeanDefreank
Contributor
Contributor

There using the same configuration on the EQ and all the servers are using the same configuration.

Now I just notice another thing, am trying to remove one datastore on the same ESX server having the issue and no luck. It says remove complete and rescan HBA, then after checking the static discovery... the datastore still in there.

What can I do? something must be wrong the the ESX?

Thanks in advance.

0 Kudos
NeilRHunter
Enthusiast
Enthusiast

Is the LUN still mapped to the iscsi hba/nic?

Also, is the fourth server allowed to map to the LUN?

0 Kudos
JeanDefreank
Contributor
Contributor

Yes it is, I took a print screen to give you a better idea, the two red lines are the datastore's that I want to remove from my ESX Server.

All my ESX servers (4 ESX servers configured in cluster) have read/write access to all my datastores... and Its only one of them giving a hard time trying to add a new datastore... and anonther issue is trying to remove two old datastore that is not even on my SAN... It has been deleted... (The two datastore's are showing up only on the same ESX server having the issue, in this case VM04).

Am giving you another print screen with the error message that am getting every time I try to add a new Datastore located on a Dell EqualLogic PS4000E.

Am not a VMware guru (Expert), so if you guys want me to give you print screen's, just let me know and I'll go ahead giving you that. Just in case I dont have the right answer for you...

Thanks in advance guys and sorry about my english.

I really really appreciated.

JD

0 Kudos
mlubinski
Expert
Expert

did you add this "problematic" host iqn name to EQL group for specified lun? (of course if you use that feature)?

from this problematic host you can vmkping to EQL?

[I]If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points[/I]
JeanDefreank
Contributor
Contributor

Yes it can, actually the 4th server is running right now using others LUN's as well just like the others, is just the 4th one the one having problems removing that LUN.

So, my ESX Host it have communication between my EQL and the ESX.

what can I do now.... Somebody heeeeeelp meeee!

Thanks

JD

0 Kudos
mlubinski
Expert
Expert

login with console or ssh to this esx4 and do following: vmkping 10.10.1.5

paste here output.

also what's real issue, because first you said about adding lun, now you say about removing lun, so i am confused a bit...

[I]If you found this or any other answer useful please consider the use of the Helpful or correct buttons to award points[/I]
0 Kudos