VMware Cloud Community
Felix001
Contributor
Contributor

ESX4 and Adaptec Storage Manager

Has anyone managed to get the Adaptec Storage Manager to work.

After I install the rpm and try running /usr/StorMan/StorMan.sh i get the following error :

# /usr/StorMan/StorMan.sh
Exception in thread "main" java.lang.ExceptionInInitializerError
Caused by: java.awt.HeadlessException:
No X11 DISPLAY variable was set, but this program performed an operation which requires it.
at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:159)
at java.awt.Window.<init>(Window.java:317)
at java.awt.Frame.<init>(Frame.java:419)
at java.awt.Frame.<init>(Frame.java:384)
at javax.swing.JFrame.<init>(JFrame.java:150)
at com.ibm.sysmgt.raidmgr.mgtGUI.Launch.<clinit>(Launch.java:214)

When i try and connect via the ASM GUI client on a windows device it just says it is "unable to connect to the remove system". When i check it is trying to connect to port 8003 which isnt listening on the device.

Anyone any ideas ??

Reply
0 Kudos
4 Replies
wila
Immortal
Immortal

Hello,

I've moved your thread from vSphere vNetwork to vSphere Storage.

Is the package that you are trying to install certificated for ESX vSphere?

The error messages in your output here make me think that it is for RHEL or similar system as it complains that it requires a desktop environment.



--
Wil
_____________________________________________________
VI-Toolkit & scripts wiki at http://www.vi-toolkit.com

Contributing author at blog www.planetvm.net

Twitter: @wilva

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos
Felix001
Contributor
Contributor

The rpm that I installed was for Linux 32-bit and confirmed that it was supported on ESX3 and ESX3.5. Though Im using 4 I wouldnt of thought there would be of been much difference.

I managed to get the command line queries working but there are no binaries on ESX to allow me to send an email.

Reply
0 Kudos
Radio1
Contributor
Contributor

I hope this isn't too late. Yes. I am using it and it works great. You have to download the RPM from adaptec. Install it and then open ports on the firewall. The GUI portion on thew host does not work, but the remote gui works great.

Reply
0 Kudos
BenConner
Contributor
Contributor

Hi,

Where did you find the rpm?  I was googling for it and found the following on the ask.adaptec.com site:

Support for ESXi Server 3.5 and 4.0:
There are AACRAID drivers embedded in ESXi Server 3.5 and 4.0 (see  VMware Certified Compatibility Guides) but there is no Management  Software (ASM or ARCCONF) or monitoring (CIM) available from Adaptec.

??

--Ben

Reply
0 Kudos