GrantLui
Contributor
Contributor

Datastore reports incorrect size ESXi

Hi, just created a new VM on a shared storage (IBM DS3400), the setting was NOT using thin provisioning and independent disk which does not affect by snap shot.

However, after the creation is completed, the used storage that the VM's summary page reporting is incorrect, I've got only a few Kbs. And then I tried to browse by datastore browser, the size of the .vmdk is.... to my surprise.... is 0Kb.... but the datastore details is reporting something seems to be reasonable.

Any hints? I'm using ESXi 4.0.0, 261974

Cheers!

Skynet Corporation Limited
0 Kudos
6 Replies
athlon_crazy
Virtuoso
Virtuoso

Double check from VM setting (Virtual Disk) whether it's thick or thin. Do you get correct size when you run this command $ls -l /vmfs/volumes/datastore/yourVM....

http://www.no-x.org
0 Kudos
GrantLui
Contributor
Contributor

Yes it's thick as the client reported and during the VM creation I choosed FT.

The xxx-1-flat.vmdk is correct under the CLI, except in the vsphere client.

Skynet Corporation Limited
0 Kudos
athlon_crazy
Virtuoso
Virtuoso

Probably you need to restart ESXi management service.

http://www.no-x.org
0 Kudos
GrantLui
Contributor
Contributor

tried to restart the host, but reporting remains the same, size still not correct.

any other ideas?

Skynet Corporation Limited
0 Kudos
scrookston
Enthusiast
Enthusiast

Were you ever able to get this resolved? What did you do to resolve it?

Sean http://www.seancrookston.com http://www.twitter.com/seancrookston
0 Kudos
GrantLui
Contributor
Contributor

Never, I just left it there and I don't see any significant problem on using it, but yea...  still want to know what the problem is

Skynet Corporation Limited
0 Kudos