Task conflict with Update Manager

Jump to solution

Hello,

we have an annoying issue when the Update Manager puts a host into maintenance mode.

- When vSphere Replication is enabled an "Install" task runs on the Host after entering Maintenance mode

- This Task conflicts with the install task from the vSphere Update Manager (another installation is in Progress)

The result is, that the Remediation if the Host fails.

Version:

- vSphere 6.7 Update 3 (Latest Build)

- vSphere Replication 8.3.1

Is there any workaround known?

Best wishes,

Markus

https://mycloudrevolution.com | https://twitter.com/vMarkus_K | https://github.com/vMarkusK
Tags (2)
0 Kudos
1 Solution

Accepted Solutions
VMware Employee
VMware Employee

Hi vMarkusK1985

vSphere replication automatically pushes hms vibs to all ESXi hosts in vCenter. This is expected and you can disable the auto-install feature post deployment:

1. SSH to vSphere replication appliance and run these commands:

/opt/vmware/hms/bin/hms-configtool -cmd reconfig -property hms-auto-install-vr2c-vib=false

/opt/vmware/hms/bin/hms-configtool -cmd reconfig -property hms-auto-install-hbragent-vib=false

Once disabled, you can check the values in /opt/vmware/hms/conf/hms-configuration.xml file. One of the parameters might not exist on newer versions(8.x), however still check the xml file

2. Restart hms service:  service hms restart

This does not impact existing or new replications

I hope that helps

View solution in original post

3 Replies
VMware Employee
VMware Employee

Hi vMarkusK1985

vSphere replication automatically pushes hms vibs to all ESXi hosts in vCenter. This is expected and you can disable the auto-install feature post deployment:

1. SSH to vSphere replication appliance and run these commands:

/opt/vmware/hms/bin/hms-configtool -cmd reconfig -property hms-auto-install-vr2c-vib=false

/opt/vmware/hms/bin/hms-configtool -cmd reconfig -property hms-auto-install-hbragent-vib=false

Once disabled, you can check the values in /opt/vmware/hms/conf/hms-configuration.xml file. One of the parameters might not exist on newer versions(8.x), however still check the xml file

2. Restart hms service:  service hms restart

This does not impact existing or new replications

I hope that helps

View solution in original post

Thanks for the workaround!

Am I the only one with the problem?

Is there any official fix planned?

https://mycloudrevolution.com | https://twitter.com/vMarkus_K | https://github.com/vMarkusK
0 Kudos
VMware Employee
VMware Employee

This issue has been reported by other users as well and the only option to stop these events is by disabling the auto install. Please refer following KB for more information --> VMware Knowledge Base

0 Kudos