How can I fix no element found: line 1, column 0 error when trying to Save the Configuration for vSphere Replication Appliance

As in the title, when saving the Configuration settings from the web interface (on port 5480) I get a red error message that says

"no element found: line 1, column 0"

This appears in red at the top of the config settings. The same error appears when trying to click the button near the bottom that says "Start" the VRM Service.

I couldn't find any other posts talking about this error. It seems to me like it's something in the web interface, so is there any way to do the following from the command line:

1. Change the Configuration Settings

2. Start the VRM Service

If there is a way I can fix the original error message and just use the web interface then that would be much preferred.

Hope somebody here can give me a hand as not getting anywhere with resolving the "no element found" error.

Thanks in advance.

9 Replies
VMware Employee
VMware Employee

Can you please include a screenshot?

0 Kudos


I also had this same message when attempting to register against external PSC 6.0 U2. So I powered off the appliance and powered so it would force it to read the OVF config again. Registering this time gave the error

Error applying startup configuration. Please check the provided DB information. I'm using embedded database.

From the hms.log file


org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'entityManagerFactory' defined in class path resource [META-INF/hmsconfig.xml]: Invocation of init method failed; nested exception is javax.persistence.PersistenceException: [PersistenceUnit: hibernate] Unable to build EntityManagerFactory

        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1514)

        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:521)

        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:458)

        at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:293)

        at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:223)

        at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:290)

        at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:191)

        at org.springframework.context.support.AbstractApplicationContext.getBean(AbstractApplicationContext.java:1119)

        at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:924)

        at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:479)

        at com.vmware.jvsl.util.SpringService.init(SpringService.java:152)

        at com.vmware.jvsl.util.SpringService.init(SpringService.java:125)

        at com.vmware.jvsl.util.SpringService.<init>(SpringService.java:61)

        at com.vmware.hms.HmsSingletonSpringService.<init>(HmsSingletonSpringService.java:109)

        at com.vmware.hms.HmsSingletonSpringService.init(HmsSingletonSpringService.java:88)

        at com.vmware.hms.App.main(App.java:123)

Caused by: javax.persistence.PersistenceException: [PersistenceUnit: hibernate] Unable to build EntityManagerFactory

        at org.hibernate.ejb.Ejb3Configuration.buildEntityManagerFactory(Ejb3Configuration.java:915)

        at org.hibernate.ejb.Ejb3Configuration.buildEntityManagerFactory(Ejb3Configuration.java:890)

        at org.hibernate.ejb.HibernatePersistence.createContainerEntityManagerFactory(HibernatePersistence.java:74)

        at org.springframework.orm.jpa.LocalContainerEntityManagerFactoryBean.createNativeEntityManagerFactory(LocalContainerEntityManagerFactoryBean.java:290)

        at org.springframework.orm.jpa.AbstractEntityManagerFactoryBean.afterPropertiesSet(AbstractEntityManagerFactoryBean.java:310)

        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.invokeInitMethods(AbstractAutowireCapableBeanFactory.java:1573)

        at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.initializeBean(AbstractAutowireCapableBeanFactory.java:1511)

        ... 15 more

Caused by: org.hibernate.HibernateException: Missing column: collectionMoRefServerGuid in public.changerecordentity

        at org.hibernate.mapping.Table.validateColumns(Table.java:289)

        at org.hibernate.cfg.Configuration.validateSchema(Configuration.java:1275)

        at org.hibernate.tool.hbm2ddl.SchemaValidator.validate(SchemaValidator.java:155)

        at org.hibernate.internal.SessionFactoryImpl.<init>(SessionFactoryImpl.java:500)

        at org.hibernate.cfg.Configuration.buildSessionFactory(Configuration.java:1744)

        at org.hibernate.ejb.EntityManagerFactoryImpl.<init>(EntityManagerFactoryImpl.java:94)

        at org.hibernate.ejb.Ejb3Configuration.buildEntityManagerFactory(Ejb3Configuration.java:905)

        ... 21 more

0 Kudos

Update: this led to VMware KB: The HMS service does not start after upgrade to VMware vSphere Replication 5.5, 5.8 or 6....

step 3 failed as it couldn't find a service with this name. Probably due to this being VR 6.1. However, running the remaining steps resolved my issue and registration completed successfully.

0 Kudos

I had this exact same issue with VRA 6.1. Tried all the usual troubleshooting steps, rebooting etc. but nothing worked. I logged this to VMware support who advised to redeploy the appliance but I was unable to unregister the appliance to start again.

I finally POWERED OFF (not reboot) the appliance, powered it on again and it saved my configuration immediately and worked again.

This messed me around for 2+ weeks, and the solution was really simple in the end - so annoying.

Hope this helps.



vExpert 2014 - 2018 | VCP6-DCV | http://www.jonmunday.net | @JonMunday77

Thanks, it worked for me

0 Kudos

Same for ver. 6.5 --> Shut down and power the VA back on fixed it for me



0 Kudos

Exactly the same issues with Build 4633956

Glad I found this thread!

This is causing issues with the VVD DTK deployment which the DTK cannot complete the configuration.

0 Kudos

Thanks! I got OP's error too. Powering off\on helped with re-registering vSR to the vCenter after upgrading to 6.1.2.

0 Kudos

If any have the same problem.

1. you need to renew the certificate with the fully qualified domain name from your vcenter server at LookupService Address like https://FQDN:7444/lookupservice/sdk

enter your SSO Administrator and passwort, klick on Generate and install at "Install a new SSL Certificate"

2. After first step is done you'll receive an error message and the service wont start up. You need to klick on Save and Restart, a message pop up to accept the cerificate because it's not trusted.

klick accept and nothing more! The service wont start up again!

3. Power off the VRA in vsphere client not vcenter! Hard power off, not restart!

4. Power on the VRA in Vcenter Appliance! Not in vsphere client !!

Now anything should work

Good luck

My next step because of a lot problems with vcenter replication is installing veeam

0 Kudos