Rajaram2k
Contributor
Contributor

Error : local variable “host” referenced before assignment & retrieving vr network isolation info -vSphere Replication Appliance 8.2

11.pngCapture.JPGCapture.JPG

Incorrect or missing DNS configurations will cause services in firstboot to fail.

Resolution

NTP sync

vSphere Replication Appliance deployments utilizing a fully qualified domain name (FQDN) are resolvable by a DNS server.

Ensure that Reverse lookup is implemented using PTR records.

Ensure the network and portgroup the vCenter Server Appliance is deployed to can reach a DNS Server.

0 Kudos
6 Replies
SudhirH
Contributor
Contributor

I am facing similar issue with 8.2. I have used IP address instead of FQDN. NTP is in sync. Is there something else that I need to check?

0 Kudos
Exxact
Contributor
Contributor

I'm having this same issue. NTP is in sync, i'm using IP addresses instead of FQDNs, DNS is reachable and can be queried. This is the second time I've attempted this.. it simply doesn't want to work.

pastedImage_0.pngpastedImage_1.png

0 Kudos
EDub24
Contributor
Contributor

This error is caused by an un-resolvable HMS IP address. To work around this issue, after logging into the VR VAMI and receiving this error, SSH into the VR appliance and add the vSphere Replication IP address and FQDN to the /etc/hosts file on the appliance. After saving your changes, return to the VAMI and enter the username and password combo for your SSO administrator and then click "Save and Restart Service" under ACTIONS. Cheers.

0 Kudos
paul007_ts
Contributor
Contributor

you mentioned adding the vSphere Replication IP address and FQDN to the /etc/hosts file on the appliance.

Is the vSphere Replication IP stand for the Replication Appliance IP?

And what is the FQDN? The FQDN of vCenter?

0 Kudos
brunovane
Contributor
Contributor

Im facing this exactly problem, using IP address.

This need that VMware has to DNS and FQDN is a pain...

Always worked with just IP address in all of my vCenter deployments, now this 6.7 version is just a pain.

Did you manage to solve this?

0 Kudos
Exxact
Contributor
Contributor

Yes, after following what EDub24​ said. I added hostnames and ip addresses for all of my ESXi appliances. I also re-created all of my vmkernel adapters and configured them (direct connection). It's working great, except that now I get a PSOD randomly in 0-24 with replication enabled.. but that's due to a resolved bug in my slightly outdated ESXi server.

0 Kudos