VMware {code} Community
memetom
Contributor
Contributor

vim and vim25

Downloaded VI API SDK and seeing two directories under wsdl

vim

vim25

which one should I use?

Also I got few error messages when trying to convert to java following programing guide.

WSDL2Java -O-1 -Nurn:vim2Service=com.vmware.vim

-Nurn:vim2=com.vmware.vim -o . vim.wsdl

At the end I made two changes as marked in bold

C:\VI-SDK\SDK\wsdl\vim25>java -Xmx512m org.apache.axis.wsdl.WSDL2Java -O-1 -Nurn

:vim25Service=com.vmware.vim -Nurn:vim25=com.vmware.vim -o . vim.wsdl

does changing from vim2 to vim25 okay to do?

Thanks,

Tom

Reply
0 Kudos
1 Reply
tpcool
Enthusiast
Enthusiast

I think you should use vim25.

vim25 is backward compatible with vim2

Reply
0 Kudos