varun_tbd
Contributor
Contributor

Getting the VI Client to use HTTP to communicate with ESX3.5/VCS 2.5

Hi,

I wanted to make my VI client communicate with ESX 3.5 and/or VCS 2.5 using HTTP instead of HTTPS. I have followed the instructions as given in the developers guide and changed the accessMode to httpAndHttps for sdk and MOB in /etc/vmware/hostd/proxy.xml. I did a service mgmt-vmware restart on the console after this. I also enabled connections from the ESX Server to the outside using "esxcfg-firewall -o 80,tcp,out,http". The Client in this case defaults to using https. I then switched to using httpOnly for the accessMode and then couldnt get in. I also tried changing the configuration of the local VI Client at C:\Program Files\VMware\Infrastructure\Virtual Infrastructure Client\Launcher\VpxClient.exe.config but had still was not able to connect using HTTP.

I am using WireShark on my Desktop to find out what packets are being sent and the above three tries have either resulted in failed logins or HTTPS being used by the client.

Is it possible to force my VI Client to communicate with my ESX 3.5 or a VC 2.5 Server.If so, how can I do the same?

Thanks

Regards

Varun

0 Kudos
5 Replies
njain
Expert
Expert

Hi Varun,

The instructions given in the developers guide to change the access mode to enable HTTP for SDK and MOB, is to allow users to configure target servers (ESX/VC) to support regular (non-SSL) HTTP, to simplify the client-side setup, development, and testing. VI Client is the most secure access method and the target servers cannot be configured to communicate over non-SSL using VI Client.

Hope the above information helps.

Regards,

Neha

Jeff3
Contributor
Contributor

The VI Client has a line in its config file (VpxClient.exe.config):

add key = "protocolports" value = "https:443"

So I can use this to change the port number, but not the protocol?

It would be great to see the soap messages that the VI Client sends...it could help one figure out how data objects should be populated for certain tasks. Is there another way to do that?

Thanks.

0 Kudos
varun_tbd
Contributor
Contributor

Hi Neha,

Thanks for the prompt response. It helps to know the target servers cannot be configured to communicate with the client using HTTP and saved me a few more hours of googling around.

Regards

Varun

0 Kudos
varun_tbd
Contributor
Contributor

Hi Jeff,

I had already tried changing the add key without much luck earlier. So the port number in VpxClient.exe.config can be changed but somehow not the protocol.

Thanks again.

Regards

Varun

0 Kudos
akutz
Hot Shot
Hot Shot

Actually, this is quite possible.

0 Kudos