mgstick
Contributor
Contributor

Why can't I install gcc or git in vMA 5.0.0's SLES 11

I'd like to build some 3rd party software and have it available as a service in vMA 5.0. The source is in a git repository and would require gcc (among other things) to build it on the VMware SLES 11 Guest OS in vMA 5.0.

Unfortunately, no matter what I try (zypper, rpm, yast2 -i) I can't get the packages (or patterns), which I want/need to have, to install on this system. They all seem to have dependencies that for some reason can't be fulfilled on VMware SLES 11, ex.

For git:

    git-1.7.3.4-3.6.x86_64 requires git-core = 1.7.3.4, but this requirement cannot be provided

                    uninstallable providers: git-core-1.7.3.4-3.6.i586[opensuse]

                                                          git-core-1.7.3.4-3.6.x86_64[opensuse]

For git-core:

    git-core-1.7.3.4-3.6.x86_64 requires perl-base = 5.12.3, but this requirement cannot be provided

                    uninstallable providers: perl-base-5.12.3-11.14.1.i586[opensuse]

                                                          perl-base-5.12.3-11.14.1.x86_64[opensuse]

For gcc:

    gcc-4.5-19.1.x86_64 requires gcc45, but this requirement cannot be provided

                    uninstallable providers: gcc45-4.5.1_20101208-9.8.i586[opensuse]

                                                          gcc45-4.5.1_20101208-9.8.x86_64[opensuse]

For gcc45:

    gcc45-4.5.1_20101208-9.8.x86_64 requires libgcc1 >= 4.5.1_20101208-9.8, but this requirement cannot be provided

                    uninstallable providers: libgcc45-4.5.1_20101208-9.8.i586[opensuse]

                                                          libgcc45-4.5.1_20101208-9.8.x86_64[opensuse]

I don't know what the problem is here.

  • Doesn't yast support installing multiple versions of packages?
  • Do I need to include other repositories? If so, which ones?
  • Am I missing some fundamental concept?
  • Did VMware break this on purpose? If so, why?

Any help would be appreciated.

Thank you!

0 Kudos
2 Replies
BlakeGreerCPW
Contributor
Contributor

Before I did the following I ran "zypper up" and installed all pending updates. You can probably skip this step, but I wanted to make any potential readers aware of this in case they run into problems.

I installed gcc and kernel headers so the vmtools would compile. I got the same errors as you when trying to install both gcc and kernel headers.

This is what I typed:

#> zypper in gcc

Problem: gcc-4.5-19.1.x86_64 requires gcc45, but this requirement cannot be provided
  uninstallable providers: gcc45-4.5.1_20101208-9.8.i586[opensuse]
                   gcc45-4.5.1_20101208-9.8.x86_64[opensuse]
Solution 1: Following actions will be done:
  deinstallation of libgcc43-4.3.4_20091019-0.7.35.x86_64
  deinstallation of libstdc++43-4.3.4_20091019-0.7.35.x86_64
Solution 2: do not ask to install a solvable providing gcc
Solution 3: break gcc by ignoring some of its dependencies

Choose solution 1. This will uninstall any incompatabilities and install gcc correctly. Note: some packages would error and I'd get an abort,retry,ignore. A retry will usually solve the problem, if not, ignore and move on.

Once I did the previous, along with the kernel headers, the vmtools script found gcc and the kernel headers and compiled right away. That kind of confirmed to me that gcc installed correctly.

Thanks,

Blake

0 Kudos
dermoth
Contributor
Contributor

To get Git and Rsync on vMA 5.5 I manually installed the following packages, which I got from official SLES repositories:

curl-7.19.6-2.1.x86_64.rpm

git-1.6.4.2-3.3.x86_64.rpm

git-core-1.6.4.2-3.3.x86_64.rpm

libcurl4-7.19.6-2.1.x86_64.rpm

libidn-1.10-4.2.x86_64.rpm

libopenssl1_0_0-1.0.0-5.4.x86_64.rpm

libpopt0-1.13-4.2.x86_64.rpm

libssh2-1-1.1-2.1.x86_64.rpm

perl-Error-0.17015-2.1.x86_64.rpm

rsync-3.0.6-3.3.x86_64.rpm

zlib-1.2.3-140.2.x86_64.rpm

The source for these packages (IIRC) were these (spread in multiple SLES versions):

http://download.opensuse.org/distribution/11.4/repo/oss/suse/x86_64/

http://ftp5.gwdg.de/pub/opensuse/discontinued/distribution/11.3/repo/oss/suse/x86_64/

http://ftp5.gwdg.de/pub/opensuse/discontinued/distribution/11.2/repo/oss/suse/x86_64/

I didn't have access direct web access so I did not even try zypper. I had to get the specific rpm version, not just the latest one.

UPDATE 2014-05-14: For vMA 5.5.0.1 Build 1663088 the packages needed are:

rsync-3.0.6-3.3.x86_64.rpm

libopenssl1_0_0-1.0.0-5.4.x86_64.rpm

git-1.6.4.2-3.3.x86_64.rpm

perl-Error-0.17015-2.1.x86_64.rpm

libssh2-1-1.1-2.1.x86_64.rpm

git-core-1.6.4.2-3.3.x86_64.rpm

libpopt0-1.13-4.2.x86_64.rpm

Also, NEVER attempt a vMA upgrade after installing Git as some packages differs and the update will most likely fail (definitely will for 5.5.0.0 Build 1387931).

Trying a "zypper install git" over the net will work after resolving many problems raised by zypper but will likely break the vCLI commands so I highly recommend sticking to the rpm's above.

I'm attaching a sample install script; just uncomment the line next to the appropriate vMA version. I can share the entire package with rpm files over private messages, but I won't share it here as I need to also include the SRPMs per GPL requirements and I don't have time for that right now.

Regards,

--

Thomas

0 Kudos