Mark_Twain007
Contributor
Contributor

vSphere 7 can't Register 1 VM migrating from a 5.5 instance

Jump to solution

So I am currently migrating servers from an old esxi 5.5 environment to a new 7.0 environment. 

So far all other VMs have transferred without issue. VMtion storage them to new storage array, Shutdown the VM, remove from inventory in the 5.5 environment, Register in the 7.0 environment, everything works great. 

But I have 1 random VM that when I go through the steps, and try and register the .vmx file in the new environment, nothing happens. The refresh button on the vsphere page spins for half a second and that's it. 

When I go back to the 5.5 environment, I can add it back to inventory without issue. 

Any thoughts? This is my first big VMWare migration so I'm pretty new at this process. I did read that one possibility is the .nvram file could be missing, but that file is in the folder. 

Thanks

 

0 Kudos
1 Solution

Accepted Solutions
continuum
Immortal
Immortal

Does
ethernet1.networkName = "iSCSI-EQ"
exist ?

Remove
SCSI0:0.ctkEnabled = "true"
or change to
scsi0:0.ctkEnabled = "true"

 

 


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

View solution in original post

0 Kudos
6 Replies
e_espinel
Commander
Commander

Hello.
If the problem so far is in a single VM, you should check the following compatibility points in the VM:
The Operating System

Hardware version of the VM

Storage vMotion Requirements and Limitations

Link:https://vdc-download.vmware.com/vmwb-repository/dcr-public/24be7af7-d9cd-48d9-bab8-8c91614be19d/0ca3...

 

 

Enrique Espinel
Senior Technical Support IBM, Lenovo, VMware vSphere and Veeam Backup.
VMware VSP-SV, VTSP-SV, VTSP-HCI, VTSP 5
Please mark my comment as Correct Answer or assign Kudos if my answer was helpful to you, Thank you.
Пожалуйста, отметьте мой комментарий как Правильный ответ или поставьте Кудо, если мой ответ был вам полезен, Спасибо.
0 Kudos
continuum
Immortal
Immortal

Show us the vmx file of that VM - it may show a detail not compatible with esxi7.

 

 


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
Mark_Twain007
Contributor
Contributor

Here is the .VMX file. Hopefully you can find something I am missing:

.encoding = "UTF-8"
config.version = "8"
virtualHW.version = "8"
vmci0.present = "TRUE"
displayName = "GCNADM"
extendedConfigFile = "GCNADM.vmxf"
numvcpus = "4"
memSize = "16384"
sched.cpu.units = "mhz"
sched.cpu.latencySensitivity = "normal"
tools.upgrade.policy = "manual"
scsi0.virtualDev = "lsisas1068"
scsi0.present = "TRUE"
vmci.filter.enable = "TRUE"
ide1:0.startConnected = "FALSE"
ide1:0.deviceType = "cdrom-image"
ide1:0.fileName = "emptyBackingString"
ide1:0.present = "TRUE"
scsi0:0.deviceType = "scsi-hardDisk"
scsi0:0.fileName = "GCNADM.vmdk"
sched.scsi0:0.shares = "normal"
scsi0:0.present = "TRUE"
floppy0.startConnected = "FALSE"
floppy0.clientDevice = "TRUE"
floppy0.fileName = "vmware-null-remote-floppy"
ethernet0.virtualDev = "e1000e"
ethernet0.networkName = "VM Network"
ethernet0.addressType = "vpx"
ethernet0.generatedAddress = "00:50:56:9d:9c:7d"
ethernet0.present = "TRUE"
ethernet1.virtualDev = "vmxnet3"
ethernet1.networkName = "iSCSI-EQ"
ethernet1.addressType = "vpx"
ethernet1.generatedAddress = "00:50:56:9d:1c:9b"
ethernet1.present = "TRUE"
guestOS = "windows8srv-64"
toolScripts.afterPowerOn = "TRUE"
toolScripts.afterResume = "TRUE"
toolScripts.beforeSuspend = "TRUE"
toolScripts.beforePowerOff = "TRUE"
tools.syncTime = "FALSE"
tools.guest.desktop.autolock = "FALSE"
uuid.bios = "42 1d 69 88 01 3a 7e b6-cf b9 37 68 4d 48 dc 7e"
vc.uuid = "50 1d 48 16 96 b6 78 2d-42 b6 32 08 03 19 f8 1d"
chipset.onlineStandby = "FALSE"
nvram = "GCNADM.nvram"
pciBridge0.present = "true"
svga.present = "true"
pciBridge4.present = "true"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge4.functions = "8"
pciBridge5.present = "true"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge5.functions = "8"
pciBridge6.present = "true"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge6.functions = "8"
pciBridge7.present = "true"
pciBridge7.virtualDev = "pcieRootPort"
pciBridge7.functions = "8"
hpet0.present = "true"
virtualHW.productCompatibility = "hosted"
disk.EnableUUID = "true"
replay.supported = "FALSE"
pciBridge0.pciSlotNumber = "17"
pciBridge4.pciSlotNumber = "21"
pciBridge5.pciSlotNumber = "22"
pciBridge6.pciSlotNumber = "23"
pciBridge7.pciSlotNumber = "24"
scsi0.pciSlotNumber = "160"
ethernet0.pciSlotNumber = "192"
vmci0.pciSlotNumber = "32"
scsi0.sasWWID = "50 05 05 68 01 3a 7e b0"
vm.genid = "3922565332226996908"
vm.genidX = "-6786019171208232831"
hostCPUID.0 = "0000000d756e65476c65746e49656e69"
hostCPUID.1 = "000206d70020080017bee3ffbfebfbff"
hostCPUID.80000001 = "0000000000000000000000012c100800"
guestCPUID.0 = "0000000d756e65476c65746e49656e69"
guestCPUID.1 = "000206d700020800969822031fabfbff"
guestCPUID.80000001 = "00000000000000000000000128100800"
userCPUID.0 = "0000000d756e65476c65746e49656e69"
userCPUID.1 = "000206d700200800169822031fabfbff"
userCPUID.80000001 = "00000000000000000000000128100800"
evcCompatibilityMode = "FALSE"
monitor.phys_bits_used = "40"
vmotion.checkpointFBSize = "4194304"
softPowerOff = "TRUE"
toolsInstallManager.lastInstallError = "0"
tools.remindInstall = "FALSE"
toolsInstallManager.updateCounter = "1"
vmotion.checkpointSVGASize = "7340032"
ethernet1.pciSlotNumber = "224"
cpuid.coresPerSocket = "2"
sched.scsi0:0.throughputCap = "off"
guestinfo.driver.vmci.version = "9.8.16.0"
guestinfo.driver.vmxnet3.version = "1.9.2.0"
SCSI0:0.ctkEnabled = "true"
ctkEnabled = "true"
sched.cpu.min = "0"
sched.cpu.shares = "normal"
sched.mem.min = "0"
sched.mem.minSize = "0"
sched.mem.shares = "normal"
migrate.hostlog = "./GCNADM-4ab06cb5.hlog"
sched.swap.derivedName = "/vmfs/volumes/62a0ec5d-b3d27ae5-2c28-1402ec74a35c/GCNADM/GCNADM-4ab06cb5.vswp"
uuid.location = "56 4d ae b8 53 e1 d1 96-3e 94 45 7e e8 76 5b 09"
replay.filename = ""
scsi0:0.redo = ""
vmci0.id = "1296620670"
cleanShutdown = "TRUE"

0 Kudos
continuum
Immortal
Immortal

Does
ethernet1.networkName = "iSCSI-EQ"
exist ?

Remove
SCSI0:0.ctkEnabled = "true"
or change to
scsi0:0.ctkEnabled = "true"

 

 


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
continuum
Immortal
Immortal

Or use this one :

Spoiler
.encoding = "UTF-8"
config.version = "8"
cpuid.coresPerSocket = "2"
disk.EnableUUID = "true"
displayName = "GCNADM"
ethernet0.networkName = "VM Network"
ethernet0.pciSlotNumber = "192"
ethernet0.present = "TRUE"
ethernet0.virtualDev = "e1000e"
ethernet1.pciSlotNumber = "224"
ethernet1.present = "TRUE"
ethernet1.virtualDev = "vmxnet3"
evcCompatibilityMode = "FALSE"
extendedConfigFile = "GCNADM.vmxf"
floppy0.clientDevice = "TRUE"
floppy0.fileName = "vmware-null-remote-floppy"
floppy0.startConnected = "FALSE"
guestOS = "windows8srv-64"
hpet0.present = "true"
ide1:0.deviceType = "cdrom-image"
ide1:0.fileName = "emptyBackingString"
ide1:0.present = "TRUE"
ide1:0.startConnected = "FALSE"
memSize = "16384"
monitor.phys_bits_used = "40"
numvcpus = "4"
nvram = "GCNADM.nvram"
pciBridge0.pciSlotNumber = "17"
pciBridge0.present = "true"
pciBridge4.functions = "8"
pciBridge4.pciSlotNumber = "21"
pciBridge4.present = "true"
pciBridge4.virtualDev = "pcieRootPort"
pciBridge5.functions = "8"
pciBridge5.pciSlotNumber = "22"
pciBridge5.present = "true"
pciBridge5.virtualDev = "pcieRootPort"
pciBridge6.functions = "8"
pciBridge6.pciSlotNumber = "23"
pciBridge6.present = "true"
pciBridge6.virtualDev = "pcieRootPort"
pciBridge7.functions = "8"
pciBridge7.pciSlotNumber = "24"
pciBridge7.present = "true"
pciBridge7.virtualDev = "pcieRootPort"
scsi0.pciSlotNumber = "160"
scsi0.present = "TRUE"
scsi0.sasWWID = "50 05 05 68 01 3a 7e b0"
scsi0.virtualDev = "lsisas1068"
scsi0:0.deviceType = "scsi-hardDisk"
scsi0:0.fileName = "GCNADM.vmdk"
scsi0:0.present = "TRUE"
scsi0:0.redo = ""
softPowerOff = "TRUE"
svga.present = "true"
virtualHW.productCompatibility = "hosted"
virtualHW.version = "8"
vmci0.pciSlotNumber = "32"
vmci0.present = "TRUE"


Ulli


________________________________________________
Do you need support with a VMFS recovery problem ? - send a message via skype "sanbarrow"
I do not support Workstation 16 at this time ...

0 Kudos
Mark_Twain007
Contributor
Contributor

So It was either this, or when I went to remove this, I also noticed the disk drive was set to connect to an .iso file on some storage that wasn't connected to the new hosts. Either way, I made the changes and the server transferred perfectly last night. Thanks. 

0 Kudos