Kuraudo7921
Contributor
Contributor

Solved: Why Can't I click download/register button to register/download?

Jump to solution

Problem: 

VMware vSphere Hypervisor 7.0 Update3c

https://customerconnect.vmware.com/cn/group/vmware/evalcenter?p=free-esxi7&source=dwnp

STEPS:

1) Login your account, and REGISTER THE PRODUCT on the BLUE WORDs, instead of the buttons

Kuraudo7921_0-1644253393906.pngusing Exsi5 as an example because I have already solved my problem share

 

2)Found it not working, getting pissed of during the trial process

Kuraudo7921_1-1644253672209.png

Don't bother to swipe down and try all those browsers or kill those anti-ads/virus softwares(they are doing their job well)

Cuz it's not the problem that your PC is not working, it's due to the Website

It took me 30min to find another download center link from a post on CSDN.

https://customerconnect.vmware.com/cn/downloads/info/slug/datacenter_cloud_infrastructure/vmware_vsp...

Use THIS after you get rid of that product registeration process and get your license code.

Kuraudo7921_2-1644253801715.pnguse the blue words there and *pop! It just showed up, sweet!

Kuraudo7921_3-1644253911312.png

Now it's downloading good as hell.

.

Possibilities:

THE BUTTON LOST ITS URL

U'r website buttons missed a change during an upgrade;

or an intern forgot to put the URL link into the button, yet the guy remembered to get the animation working when the mouse is hover'n above it.

.

But I have no idea whether the problem just exsisted in months, or it is just there for a long time and NO ONE HAS EVER STAND OUT TO POINT IT OUT, 

or NO ONE IS FIXING IT

.

I know it's god-**bleep** hard to face-&-fix those who just want to ask someone rather than google when they have a problem.

But please, just make those should-be-working things work as it should be.

Jeez....

 

Get LINKED CLONES on ESXI PLZZZZZZZZZ!!!!!!!!
0 Kudos
1 Solution

Accepted Solutions
alex0000
Contributor
Contributor

Did some searching on the error message:  Uncaught ReferenceError: utag is not defined

This appears to be one solution for firefox when the uBlock Origin extension is installed, although there might be other reasons this problem can happen.

Open uBlock Origin > Trusted Sites
add: customerconnect.vmware.com

Apply changes

View solution in original post

Tags (3)
5 Replies
alex0000
Contributor
Contributor

Thank you, at least I know I'm not the only one that was having problems. I registered with the Product Evaluation Center for VMware vSphere 7.0 and found the same problem. When I go to my dashboard, I'm seeing:

Current Evaluations
View All
Product Evaluation Center for VMware vSphere 7.0
60 Days Remaining

When I click "Download" it takes me back here:
https://customerconnect.vmware.com/group/vmware/evalcenter?p=vsphere-eval-7#tab_download

No download possible.

If I navigate from the All Products page:
https://customerconnect.vmware.com/downloads/#all_products

Then select: VMware vSphere > View Download Components
https://customerconnect.vmware.com/downloads/info/slug/datacenter_cloud_infrastructure/vmware_vspher...

Then select: VMware vSphere Hypervisor (ESXi) 7.0U3c
https://customerconnect.vmware.com/downloads/details?downloadGroup=ESXI70U3C&productId=974&rPId=8385...

I get the message:

You either are not entitled or do not have permissions to download this product.
Check with your VMware Customer Connect Super User, Procurement Contact or Administrator.

If you recently purchased this product through VMware Store or through a third-party, try downloading later.

Download Trial

So I click "Download Trial" and it takes me back to the Product Evaluation Center where it tells me I have 59 days remaining.

This is with Firefox ESR 91.5 on Linux

0 Kudos
alex0000
Contributor
Contributor

Update: The following browsers failed to download vSphere Hypervisor from the Product Evaluation Center page:

Firefox ESR 91.5 on Debian Linux
Firefox 96.0.3 on macOS 10.12.6

In both cases the firefox pop-up blocker was either disabled, or vmware.com was added to the pop-up exceptions

The following browser worked for my download from the Product Evaluation Center page:

Safari 12.1.2 on macOS 10.12.6

Perhaps I just needed to wait an hour or two. The download appears to be available now via All Products > VMware vSphere > View Download Components: VMware vSphere Hypervisor (ESXi) 7.0U3c
https://customerconnect.vmware.com/downloads/details?downloadGroup=ESXI70U3C&productId=974&rPId=8385

0 Kudos
alex0000
Contributor
Contributor

In case someone in VMware takes a look at this, here are the error messages in the Product Evaluation Center, when we use Firefox ESR 91.5 on Linux and monitoring console in Inspector and then attempt to use the Manual Download option.

alex0000_0-1644361410976.png

As mentioned above, I got the same error with Firefox on macOS too.

Tags (3)
0 Kudos
alex0000
Contributor
Contributor

Did some searching on the error message:  Uncaught ReferenceError: utag is not defined

This appears to be one solution for firefox when the uBlock Origin extension is installed, although there might be other reasons this problem can happen.

Open uBlock Origin > Trusted Sites
add: customerconnect.vmware.com

Apply changes

Tags (3)
gpeters2
Contributor
Contributor

Holy crap - thank you for this.  Solved my problem, and a lot of others I see.  VMWare should fix this.  The problem dates back pretty far.  I did see that the link can be changed from cn to en.  Used this to redownload 7.0 U3F

https://customerconnect.vmware.com/en/downloads/details?downloadGroup=ESXI70U3F&productId=974&rPId=9...

 

0 Kudos