vmkarthik
Enthusiast
Enthusiast

Error in Active Directory Operations

Jump to solution

Hi,

I am just trying to test the new 4.1 so installed it as a VM and now trying to join the ESXi to the AD, I get the following error : "Error in Active Directory Operations"

Also when I try to join the ESXi using the DC IP its says the domain name contains Invalid Character Quite Puzzling...??

Also I have checked the Date and Time as well as DNS and Routing config.

All seems fine but still doesnt work.

Any help is Welcome.

Thanks

0 Kudos
1 Solution

Accepted Solutions
GreatWhiteTec
VMware Employee
VMware Employee

Ran into the same issue this week. Called support and after an hour we got nowhere. So, I kept trying different settings and finally found my way in.

In my case I was using my own account and I was by-passing kerberos authentication, so make sure the account you are using is a Domain admin (has permission to join/create computers in the domain) and is not by-passing pre-authentication.

The other issue was related to the domain name and username. For domain use the FQDN (mydomain.lcl). For user youraccount , don't use mydomain\youraccount format. Even though I've read that you can enter it like this, it did NOT work for me.

This 3 things fixed my issue. Now, all my hosts are on the domain.

Hope this helps...

A+, DCSE, MCP, MCSA, MCSE, MCTS, MCITP, MCDBA, NCDA, NCIE-SAN, NCIE-BR, VCP4, VCP5, VCP5-DT, VCAP5-DCA _____________________ If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful.

View solution in original post

0 Kudos
2 Replies
GreatWhiteTec
VMware Employee
VMware Employee

Ran into the same issue this week. Called support and after an hour we got nowhere. So, I kept trying different settings and finally found my way in.

In my case I was using my own account and I was by-passing kerberos authentication, so make sure the account you are using is a Domain admin (has permission to join/create computers in the domain) and is not by-passing pre-authentication.

The other issue was related to the domain name and username. For domain use the FQDN (mydomain.lcl). For user youraccount , don't use mydomain\youraccount format. Even though I've read that you can enter it like this, it did NOT work for me.

This 3 things fixed my issue. Now, all my hosts are on the domain.

Hope this helps...

A+, DCSE, MCP, MCSA, MCSE, MCTS, MCITP, MCDBA, NCDA, NCIE-SAN, NCIE-BR, VCP4, VCP5, VCP5-DT, VCAP5-DCA _____________________ If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful.

View solution in original post

0 Kudos
vmkarthik
Enthusiast
Enthusiast

Thanks very much.

The problem was solved by just changing the way I autheticated. I was using DC\xyz which I just changed to Usr: xyz and it went fine. Also need to be sure that the ID has Domain Admin rights.

Good to Go !!!

0 Kudos