liliang_Epson
Contributor
Contributor

EXSi 6.5 can not find driver when deploy VM as Windows Server 2012R2

Jump to solution

Dear All, who face this problem such as attached screen capture. when i deploy a VM which use O/S is Windows Server 2012R2, but this operation is failure due to HDD can not active. if your have same experience, would you give me help. thanks!issue.jpg

0 Kudos
1 Solution

Accepted Solutions
vijayrana968
Virtuoso
Virtuoso
0 Kudos
4 Replies
vijayrana968
Virtuoso
Virtuoso
0 Kudos
planetshoots
Contributor
Contributor

Driver is it asking for the cdrom?

0 Kudos
Finikiez
Champion
Champion

Which type of virtual SCSI controller you created for your VM?

Is it PVSCSI controller? If so than Windows ISO doesn't have a driver for this type of controllers by default. They can be installed only with VMware Tools.

You have two options here:

1. Change virtual SCSI controller type to LSI SAS for boot virtual disk and install windows.

2. If you really need to have boot disk connected to PVSCSI controller, than you have to inject pvscsi driver into your installation image.

https://www.derekseaman.com/2012/10/inject-vsphere-drivers-into-windows.html

PS. Also you can install Windows OS on boot disk connected to LSI SAS and that change controller type to PVSCSI

Check KB Configuring disks to use VMware Paravirtual SCSI (PVSCSI) adapters (1010398) | VMware KB

0 Kudos
liliang_Epson
Contributor
Contributor

Thanks! you are right, due to upload image file operation is not finish!

i used windows IE to upload image, only running 74%, but using chrome to do upload job. it's is success!

0 Kudos