ESXi: Cannot boot into bootable usb


First of all full disclosure I am not an expert at setting up ESXi, this is the first time I ever try to do something like this.

I am currently trying to install ESXi 7.0 on an old HP laptop with an Intel core i3 350M, the problem is that whenever I try to boot from my USB flash drive the laptop won't boot to the USB drive, it will just boot onto the existing OS in the device hard drive, I have virtualization enabled on my BIOS.

I have tried to flash the ISO image on the USB drive with Unetbootin, dd and with the default PopOs USB flasher, since my current OS is PopOS. At first I thought that my issue was the ISO file that was corrupted since after the first download I could not download it again as the vmware website would just redirect me to the myvmware homepage, after a lot of hopping between browsers with and without a VPN I was able to download ESXi 7.0 again and ESXi 6.5 and 5.5, the latter were downloaded since I thought that since the hardware is pretty old and these versions could have better hardware support, sadly it still wouldn't boot from the USB drive, then I tried to install the first ISO file I downloaded on my PopOS machine with VMware Workstation and it worked with no issues.

I also tried to boot from the USB on a more recent HP laptop with an Intel i3 2350M and it still won't boot from the USB drive, both CPU support VT-x and have virtualization enabled on the BIOS, after 6h trying to find solutions and people with the same issues as me, I gave up and resorted to this forum.

My questions are:

- Is my hardware not compatible at all? If so is this the reason why I'm not able to boot from the USB drive?

- Is my way of flashing the ISO images to the USB drive wrong?

I am aware that my hardware is not the best for virtualization, but since I only want to have a couple of VM's running Ubuntu server with ESXi I thought that this would not be a limitation since Ubuntu does not require a very powerfull system to run...

Thanks in advance to any help or tips provided!

0 Kudos
2 Replies
VMware Employee
VMware Employee

The chances of ESXi installing and running on an old laptop are small - ESXi has the drivers for servers, and version 7 has a more restrictive driver model for 3rd-party drivers.

You can check your CPU, and other hardware components here:


0 Kudos

You might have to check/modify the boot order in the BIOS. The ability to boot from USB is not dependent on ESXi hardware compatibility. Flashing a bootable ISO (whether ESXi bootable ISO or any Linux distro ISO) to a USB thumb drive can be achieved simply using dd. For dd make sure you are flashing without the partition number (example: of=/dev/sdg not of=/dev/sdg1)

As already mentioned by scott28tt, ESXi 7.0 has stricter driver requirements. The vmklinux drivers are no longer supported, therefore creating a custom VIB for a device not in the HCL is no longer an option. Many laptops come with Realtek NICs and Realtek NICs are not in the VMware ESXi HCL.

The i3-350M is a Westmere CPU. The Westmere Xeon CPUs are no longer supported with ESXi 7.0. There is also notice that that some Sandy Bridge and Ivy Bridge CPUs will no longer be supported in the future releases.

So the chances of a successful install of ESXi 7.0 on this old laptop is very, very slim to none.

I think it is better to use VMware Workstation/Player to run the Ubuntu servers as VMs. You can also create an ESXi VM using Workstation/Player if you are still interested to have some hands-on to ESXi. However, to run VMs inside the ESXi VM means that there has to be more RAM at the host and a more modern CPU (preferably at least Haswell or newer) to have any measure of responsive VMs.

0 Kudos