factroy
Contributor
Contributor

ESXI 6.5 lowering syslog logging levels (again..)

Hi,

there were a couple of discussions about configuring the syslog logging level of an ESXi server. So, I we all know these links:

Enabling trivia logging in VMware vCenter Server (1001584) | VMware KB

and

vSphere Documentation Center

But I still have some issues in reducing the 'verbosity' of an ESXi 6.5 host:

In my config.xml in /etc/vmware/hoistd I have this code. My understanding: "Only syslog messages 'error' or more severe"

      <!-- default log level -->

     <level>error</level><!-- <level/> -->

      <!-- If true, logs to syslog -->

      <outputToSyslog>true</outputToSyslog>

      <!-- syslog configuration.  Only used if outputToSyslog is true. -->

      <syslog>

         <!-- syslog identifier to use when logging -->

         <ident>Hostd</ident>

         <!-- syslog facility to use when logging -->

         <facility>local4</facility>

But I still get syslog messages like this:

2016-11-23T18:40:48.222Z vmh-01.samos Hostd: trivia hostd[9E40B70] [Originator@6876 sub=Snmpsvc.http.HTTPService] HTTP Response: ....

2016-11-23T18:40:01.722Z vmh-01.samos hostd-probe: info -[7F9E980]

So, any explanation why this is the case?  Any other configuration file?

Or are these options overwritten somewhere?

Thanks for refreshing the discussion here.

Best.

0 Kudos
2 Replies
Vme332c
Enthusiast
Enthusiast

same issue here,  have tried even bumping the global level to error (and ofcourse reloading),  but my remote syslog server is filled with logs of a much lower level than error  (more like debug,  and mainly Rhttpproxy,  which i assume is users on the web gui, but many leave it open).

this needs to be addressed.

0 Kudos
paul007_ts
Contributor
Contributor

I need for help as well. a huge amount of hostd and rhttpproxy logs are sending to the syslog server non-stop.

Environment: ESXi 7.0

0 Kudos