unsichtbare
Expert
Expert

Jumbo Frames and Failover order appear to be missing for VMkernel NIC's

Jump to solution

This is a bit of a cross-post to one I created a few days ago in ESXi 6 (I was not aware of this category).

I was trying to do a 100% Windows-client free install of vSphere 6, when I stumbled across the inability to set Jumbo Frames for VMkernel NICs, or control the failover order for the VMkernel Port Group.

Of course, I could do it at the command line, but that's no the point.

Otherwise the Embedded Host Client seems to perform well.

Thanks,

+The Invisible Admin+ If you find me useful, follow my blog: http://johnborhek.com/
0 Kudos
1 Solution

Accepted Solutions
unsichtbare
Expert
Expert

OK, here's an update - Jumbo frames are now settable for VMkernel NIC as is the Port Group Failover order!

This comes as a result of patching the host to the ESXi-6.0.0-20160804001-standard (released 08/04/2016) from the HP Customized ISO, (most recent release April 2016)

Embedded Host Client Jumbo Frames.jpg

Embedded Host Client NIC Teaming.jpg

+The Invisible Admin+ If you find me useful, follow my blog: http://johnborhek.com/

View solution in original post

0 Kudos
5 Replies
pedrocalixto
Contributor
Contributor

Open vSphere Client. Log into your host.

Go to Configuration/Networking.

You should be able to see your switches.

Click on "Properties" close to the physical adapters.

Click on your switch and click on "Edit".

On "Advanced Properties" you should see the MTU setting (which is 1500 by default).

Increase it to the valor you want.

I hope it helped.

_________________________________________ If you find an answer that helps you, please mark it as "correct" or "helpful". VCP6-DCV Http://pedrocalixto.com | virtually anything is possible
0 Kudos
unsichtbare
Expert
Expert

Thanks for your reply.

The problem is that these settings seem to be missing in the Embedded Host Client.

Yes, there is an ability to configure the MTU for the vSwitch, but that only increases the size of the pipe.

There seems to be no way of setting the MTU, nor changing Failover Order for the VMkernel Port Group for the VMkernel NIC using the Embedded Host Client

+The Invisible Admin+ If you find me useful, follow my blog: http://johnborhek.com/
0 Kudos
pedrocalixto
Contributor
Contributor

Actually, increasing the MTU will automatically enable Jumbo Frames, as you can see here: https://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=10388...

Besides, which version of ESXi are you using? I just tested here on ESXi 6.0 U2 and I was able to change the MTU size.

_________________________________________ If you find an answer that helps you, please mark it as "correct" or "helpful". VCP6-DCV Http://pedrocalixto.com | virtually anything is possible
0 Kudos
unsichtbare
Expert
Expert

So the issue is not if I am able to enable Jumbo Frames - rather is the Embedded Host Client able to perform such configurations.

The KB you cite is about a Distributed Switch and does not apply to a standard vSwitch of the sort you would create/configure with the Embedded Host client

I have further confirmed, at the command line (please see output of: esxcli network vswitch standard list and esxcli network ip interface list) that, while I was able to set vSwitch1 to an MTU of 9000, I was not able to affect the MTU of the vmk1 VMkernel NIC, as it remains at 1500, nor have I been able to set the failover order for the VMkernel Port Group, as required to implement port binding.

[root@esx101:~] esxcli network vswitch standard list

vSwitch0

   Name: vSwitch0

   Class: etherswitch

   Num Ports: 2222

   Used Ports: 4

   Configured Ports: 128

   MTU: 1500

   CDP Status: listen

   Beacon Enabled: false

   Beacon Interval: 1

   Beacon Threshold: 3

   Beacon Required By:

   Uplinks: vmnic0

   Portgroups: VM Network, Management Network

vSwitch1

   Name: vSwitch1

   Class: etherswitch

   Num Ports: 2222

   Used Ports: 6

   Configured Ports: 1024

   MTU: 9000

   CDP Status: listen

   Beacon Enabled: false

   Beacon Interval: 1

   Beacon Threshold: 3

   Beacon Required By:

   Uplinks: vmnic5, vmnic4

   Portgroups: VMkernel-iSCSI01

[root@esx101:~] esxcli network ip interface list

vmk0

   Name: vmk0

   MAC Address: 00:23:7d:3b:21:2a

   Enabled: true

   Portset: vSwitch0

   Portgroup: Management Network

   Netstack Instance: defaultTcpipStack

   VDS Name: N/A

   VDS UUID: N/A

   VDS Port: N/A

   VDS Connection: -1

   Opaque Network ID: N/A

   Opaque Network Type: N/A

   External ID: N/A

   MTU: 1500

   TSO MSS: 65535

   Port ID: 33554436

vmk1

   Name: vmk1

   MAC Address: 00:50:56:6c:b3:b8

   Enabled: true

   Portset: vSwitch1

   Portgroup: VMkernel-iSCSI01

   Netstack Instance: defaultTcpipStack

   VDS Name: N/A

   VDS UUID: N/A

   VDS Port: N/A

   VDS Connection: -1

   Opaque Network ID: N/A

   Opaque Network Type: N/A

   External ID: N/A

   MTU: 1500

   TSO MSS: 65535

   Port ID: 50331654

[root@esx101:~]

+The Invisible Admin+ If you find me useful, follow my blog: http://johnborhek.com/
0 Kudos
unsichtbare
Expert
Expert

OK, here's an update - Jumbo frames are now settable for VMkernel NIC as is the Port Group Failover order!

This comes as a result of patching the host to the ESXi-6.0.0-20160804001-standard (released 08/04/2016) from the HP Customized ISO, (most recent release April 2016)

Embedded Host Client Jumbo Frames.jpg

Embedded Host Client NIC Teaming.jpg

+The Invisible Admin+ If you find me useful, follow my blog: http://johnborhek.com/
0 Kudos