comunedilonigo
Contributor
Contributor

How to reattach a partition that has a datastore in it, possible bug

I have a partition that has already been formatted using Vmware 7.0 and I would like to "mount" it as a datastore

The gui (web) say to "select" a partition on the left side, but cannot seem to be able to do it

Is it a bug or a feature ?

pastedImage_0.png

0 Kudos
2 Replies
amohammadimir
Enthusiast
Enthusiast

run esxcfg-volume -l command on the ESXi host if it shows the missing datastore. Then, run esxcfg-volume -M <VMFS UUID | label> to mount it.

Please remember to mark the replies as answers if they helped.
0 Kudos
comunedilonigo
Contributor
Contributor

I am trying to follow this guide

https://www.virten.net/2016/11/usb-devices-as-vmfs-datastore-in-vsphere-esxi-6-5/

It works, up to thepoint when you want to detach the USB device and reattach it later

Removing is kind of OK, meaning unmount and then remove the device

Reattaching it is kind of OK, meaning that the device is recognized but attempting to browse the datastore say

pastedImage_1.png

dmesg shows

2020-09-17T15:13:16.255Z cpu16:2097251)NMP: nmp_ThrottleLogForDevice:3794: last error status from device mpx.vmhba32:C0:T0:L0 repeated 10 times

2020-09-17T15:13:16.265Z cpu16:2097251)ScsiDeviceIO: 4062: Cmd(0x459a4221d640) 0x1a, CmdSN 0x43e8 from world 0 to dev "mpx.vmhba32:C0:T0:L0" failed H:0x7 D:0x0 P:0x0 Invalid sense data: 0x44 0x0 0x42.

2020-09-17T15:13:16.328Z cpu16:2097251)ScsiDeviceIO: 4062: Cmd(0x459a42295b40) 0x1a, CmdSN 0x43ef from world 0 to dev "mpx.vmhba32:C0:T0:L0" failed H:0x7 D:0x0 P:0x0 Invalid sense data: 0x44 0x0 0x42.

2020-09-17T15:13:16.731Z cpu16:2097251)ScsiDeviceIO: 4062: Cmd(0x459a4216b400) 0x1a, CmdSN 0x440a from world 0 to dev "mpx.vmhba32:C0:T0:L0" failed H:0x7 D:0x0 P:0x0 Invalid sense data: 0x44 0x0 0x42.

2020-09-17T15:13:35.668Z cpu16:2097251)WARNING: NMP: nmp_DeviceRequestFastDeviceProbe:237: NMP device "mpx.vmhba32:C0:T0:L0" state in doubt; requested fast path state update...

2020-09-17T15:13:35.668Z cpu16:2097251)ScsiDeviceIO: 4062: Cmd(0x459a5fcd99c0) 0x1a, CmdSN 0x4416 from world 0 to dev "mpx.vmhba32:C0:T0:L0" failed H:0x7 D:0x0 P:0x0 Invalid sense data: 0x0 0x0 0x0.

2020-09-17T15:13:35.683Z cpu16:2097251)ScsiDeviceIO: 4062: Cmd(0x459a60a5f100) 0x1a, CmdSN 0x441d from world 0 to dev "mpx.vmhba32:C0:T0:L0" failed H:0x7 D:0x0 P:0x0 Invalid sense data: 0x44 0x0 0x42.

It must be possible to attach some removable storage device to ESXi, no ?

0 Kudos