VMware Cloud Community
AndyC2003
Contributor
Contributor

Delete VM Snapshots

VMware 6.7 Hoste ESXi build 20497097

Unable to delete Snapshots on VM - CommVault Media server fails backup "Too Many Backups"

2 x __GX_BACKUP_ created by CommVault backup.

Tried to DELETE ALL from Snap Mgr - error - "General system error occurred: Fault cause : GeneralVmConfigFault"

Tried to create a Snap and Consolidate - error - "General system error occurred: Fault cause : GeneralVmConfigFault"

Any ideas or KB on how to manually delete these Snaps

0 Kudos
1 Reply
AndyC2003
Contributor
Contributor

Hat-Tip/Kudos to Nesma Ghazaly a VMware Support Engineer 

Prompt response to SR raised

This worked for me 

 


Each workaround is a separate fix.

Rename the vmsd file and once a new Snapshot is taken, a new vmsd file will be created
To perform this workaround , follow the below steps:


Make a note of the datastore where the VM is stored.

Connect to the ESXi host with an SSH session.
Navigate to the datastore 

cd /vmfs/volumes/DATASTORE/VM_Name/

List all the files in the folder with: ls -l
Rename the .vmsd file to .vmsd.old

mv VM_Name.vmsd VM_Name.vmsd.old

Take or Remove the Snapshot (according to the initial issue)

OR
vMotion the affected VM to another host and test the snapshot - vMotion creates a new VM world and would use a new in-memory dictionary file.

OR
Power cycle the VM (OFF->ON)

OR
If the above workarounds didn't help, the only option is to Power OFF the VM, unregister from vCenter, Re-Register and Power ON the VM. For more information about unregistering VM and register it back to ESXi Host