emscroger
Contributor
Contributor

Unable to get catalogServiceProviderInfo

I modified one of the sample plugins to test some code.   I was able to register the extension using the MOB interface.  However, when I login to vSphere, I do not see the sample plugin, nor do I see the plugin listed under Administration -> Solutions -> Client Plug-ins.

 

When I checked the vSphere log, I saw the following error:

Unable to get catalogServiceProviderInfo for /etc/vmware/vsphere-client/cmCatalog/com.vmware.sca.2485f052-c5cc-4d5a-819c-06050e94ee56_com.vmware.samples.chassisA.html.zip

 

Does anyone have a clue what this error means/

0 Kudos
2 Replies
laurentsd
VMware Employee
VMware Employee

This error is just a side effect of something else that must be wrong in your setup.  What are the other errors/warnings for this plugin in the Virgo log?

0 Kudos
Peter_Ivanov
VMware Employee
VMware Employee

When you register an extension to vCenter, vCenter creates an entry for this extension is a service called CatalogManager (CM).

CM contains metadata about services (like endpoints). A piece of this metadata is URL to localization catalog.

On login the Web Client connects to the CM and downloads all localization catalogs. And since the one for the sample is not found, you see this error in the log.

However this cannot stop the plugin from deploying and working correctly. So there is another problem.

How do you register the extension? Are you using the MOB? If yes, can you post the extension XMl that you are using?

Also it would be very useful if you post the entire virgo log file.

Thanks,

~Peter

0 Kudos