MadhumitaJ
Contributor
Contributor

Task name is shown different on vSphere web client 6.0 and vsphere client 6.0


I have created a task on vCenter 6.0.


Task name as is shown different on vSphere web client 6.0 and vSphere client 6.0.


Task name is shown correctly on vSphere client 6.0.


But on vSphere web client 6.0 there is additional '.label' attached at end of task name.


Attached web client screenshot for reference.

26 Replies
a1exp
Contributor
Contributor

Has anybody had any feedback from VMware about the bug or got a solution that fixed it for them?

0 Kudos
Miller_Brett_R
Contributor
Contributor

I was working on this issue last week with an engineer and there is still no solution that I am aware of. Hopefully soon.

0 Kudos
Miller_Brett_R
Contributor
Contributor

Spent some time on the phone today working this issue, the problem we found was tied to a Netapp plugin that we installed in our environment. The plugin version was 6.2.1P1D1, which was where the problem ended up being. 6.2.1P1D1 is the service version for the plugin and the Virtual center JAR only interprets service versions on plugins that contain numbers, it cannot interpret letters. When it tries to process the Netapp plugin it fails and never loads the rest of the files containing the appropriate lables. The hope is that this will be resolved to read both numbers and letters in the future. Hope this helps or at least points you in the right direction.

a1exp
Contributor
Contributor

Thank you! This put me on the right track and the issue is now resolved.

For anybody else that has this issue, I checked Administration > Client Plugins but there was only the default plugins and a plugin for VCops.

I disabled that but it made no difference so I then ran through this KB article:

Cannot remove or disable unwanted plug-ins from vCenter Server and vCenter Server Appliance (1025360...

Using this I found several old NetBackup plugins that were registered under /mob but not showing up in the vSphere client.

Once I followed the instructions for un-registering them and rebooted the VCSA the problem was resolved.

0 Kudos
mrc247
Contributor
Contributor

I updated today the VCSA from 6.5 to 6.5 Update 1 and I have now the "task description label" Problem. 😞

Installed NetApp VSC Plugin Version: 6.2.1P1

Is there still another solution instead of disabling the NetApp plugin?


This is unfortunately not an option for us.

0 Kudos
mrc247
Contributor
Contributor

I have changed back to the snapshot before the update and the problem persists, although it was not there until today, how can that be?

0 Kudos
ShaneGerrish
Contributor
Contributor

I had the same issue with Task names and Host Profile settings showing the full ".label" names after an upgrade from 6.0U2 to 6.5.

I logged a support case and VMware gave me an updated "vim-services-6.1.0.jar" file to patch the web client (Flex Client).

The update file worked fine and the issue was resolved.

0 Kudos