wodge
Enthusiast
Enthusiast

Plugin seed 1.0.0 - How do we continue supporting our current Customers?

Hi,

We currently publish a plugin from the 0.9.8 seed, which has been great to work with. We have been able to develop the plugin so that it can be used by the vast majority of our Customer base.

We would like to start using 1.0.0, but there is a major problem for us, as it only supports plugins running in 6.5u2 and 6.7... Furthermore, it is only supporting the H5 client and not Flex.

Many of our Customers are running vSphere v6.0 and therefore need support for this version, together with the Flex implementation because this is the only client they can use. It would be very costly for us to start maintaining two distinct codebases, one from seed 0.9.8 and the other from seed 1.0.0., with little benefit.

As our current plugin (built from 0.9.8) already supports all versions of vSphere from 6.0 to 6.7 and includes support for the Flex client, we will just continue developing from this seed.

Could you please let us know if there are any plans to make the seed code in 1.0.0 backward compatible to all versions of vSphere 6.x, and also so that it provides continued support for the Flex client? Otherwise, could you please give advice about how we should continue to support our existing Customers within a single codebase going forward?

Many thanks,

Warren 

0 Kudos
2 Replies
laurentsd
VMware Employee
VMware Employee

Plugin seed 1.0.0 was intended to move along with our new Javascript API so unfortunately it is hard to maintain multiple versions.

If you need to keep supporting vSphere 6.0 I recommend to stick to plugin-seed 0.9.8 since it is working well for you.  Going forward you may want to update Angular, Angular-CLI and Clarity to newer versions, check their respective web pages for upgrade help.  If you want to change the i18nService to use ngx-translate you can also review the plugin-seed 1.0.0 code and apply the same technique in your existing code.

Feel free to post questions here if you need help!

0 Kudos
wodge
Enthusiast
Enthusiast

Hi,

Many thanks for your quick reply and also in the advice re. updates against 0.9.8 - it is much appreciated. So we will continue using 0.9.8 for the foreseeable future. 

To be completely sure; can you confirm there is no intention for the 1.0.0 seed code, or next iterations, to continue supporting all versions of vSphere 6.x, and no plans to continue support for the Flex client past 0.9.8?

We need to work out our strategy going forward; if this is true then we are likely to stay within 0.9.8 and not upgrade to 1.0.0. - at least until 6.x goes end of support in March 2020 / end of technical guidance in March 2022.  

Some of our Customers still prefer using Flex in 6.5, so we need to continue supporting Flex deployments and avoid any major regressions for them.

Many thanks,

Warren

0 Kudos