laurentsd
VMware Employee
VMware Employee

Localhost HTML Client problem on Windows 10 and MacOS High Sierra

FYI, the HTML Client that comes with SDK 6.5 or 6.5u1 has problem with the latest Java JDK on Windows 10 and MacOS High Sierra.

The client home page doesn't come up and the browser console shows errors such as:

Uncaught SyntaxError: Unexpected token )

clarity-angular1.min.js:38 Uncaught SyntaxError: missing ) after argument list

and

(anonymous) @ init.js:6

folder-ui.min.js:1 Uncaught ReferenceError: angular is not defined

The work-around for Windows 10 is to use Java SDK 1.8.0_144

We haven't found any work-around yet for MacOS High Sierra.  Let us know if you have one!

0 Kudos
8 Replies
wodge
Enthusiast
Enthusiast

Hi,

I'm holding off from upgrading to High Sierra on my Mac because it is used for plugin development. Could you confirm if it better to wait for a fix to this issue before doing so please?

Many thanks

0 Kudos
laurentsd
VMware Employee
VMware Employee

yeah, I would hold off upgrading to High Sierra if you need that Mac for SDK work.  I tried several versions of JDK 1.8 without success, I don't know why there is a difference with Windows 10 where JDK 1.8_144 works.  Other people in our team will pick up this issue after the Holidays, we'll post a solution as soon as we find one!

0 Kudos
wodge
Enthusiast
Enthusiast

Hi, has there been any progress re, solving the High Sierra issue please?

Many thanks

0 Kudos
laurentsd
VMware Employee
VMware Employee

Nobody had time to look at this again but it's on our list.

0 Kudos
wodge
Enthusiast
Enthusiast

Hi,

Would it be possible to provide an update on this? We really need to update the dev clients here to High Sierra, and this is the only thing blocking that currently.

Could you provide an ETA for when it is likely to be addressed/fixed please?

Thank you

0 Kudos
laurentsd
VMware Employee
VMware Employee

Found a work-around:   you need to disable the compression in the Tomcat connector for port 9443  in server/configuration/tomcat-server.xml

(i.e. replace compression="on" with compression="off" for that connector and restart the virgo server)

I just tested that with JDK 1.8.0_162 but I assume it will work with earlier ones too!

0 Kudos
_vladi_
VMware Employee
VMware Employee

Thanks Laurent,

The dev scripts have been fixed and the fixes will be part of a follow-up release.

Cheers,

Vladi

0 Kudos
wodge
Enthusiast
Enthusiast

Just to confirm - we've upgraded to high Sierra, made the change, and tested.

All works as expected. Thank you kindly.

0 Kudos