jcummings_g2
Contributor
Contributor

Failing to navigate to plugin registration page after deploying vApp

Jump to solution

Hi, we’ve been using Serengeti .8 for a bit and today found and wanted to talk a look at the new Big Data Extensions Beta package.  After I deploy the OVA, the management server starts up and I can access it (console/ssh) just fine, but when I hit the web service to register the plugin, I’m getting and SSL protocol error.

The URL (examples) I’m hitting per the documentation are https://servername.domain:8080/plugin   or https://10.20.30.40:8080/plugin   I see from the process list that Jetty/Java is handling port 8080, and when I hit the same URL without https, I see an apache/tomcat 404 page…?

Not sure exactly where to go next to troubleshoot the plugin registration.

0 Kudos
1 Solution

Accepted Solutions
admin
Immortal
Immortal

Hi,

If you want to access the plugin registration page, you need access the http://<your serengeti management server IP>:8080/register-plugin/. There is no SSL at the 8080 port.

If you need download the plugin package binary, you need access the https://<your serengeti server IP>/vcplugin/serengeti-plugin.zip.

View solution in original post

0 Kudos
13 Replies
admin
Immortal
Immortal

Hi,

If you want to access the plugin registration page, you need access the http://<your serengeti management server IP>:8080/register-plugin/. There is no SSL at the 8080 port.

If you need download the plugin package binary, you need access the https://<your serengeti server IP>/vcplugin/serengeti-plugin.zip.

0 Kudos
ChrisBedford
VMware Employee
VMware Employee

Hello,

The vSphere Big Data Extensions Administrator's and User's Guide listed the wrong URL with which register the plug-in. This has since been corrected, and a new version of the documentation has been uploaded to the Big Data Extensions Documentation forum.

As has been stated above, the correct URL with which to register the Big Data Extensions plug-in is:

     http://management-server-ip-address:8080/register-plugin

You can find this correction on page 11 of the vSphere Big Data Extensions Administrator's and User's Guide.


We apologize for any inconvenience this may have caused.


Kind Regards,

Chris Bedford

VMware Technical Publications

0 Kudos
a_landsidel
Contributor
Contributor

Did this change again, without the documentation being updated?

With the latest vApp (0.8.0.0), navigating to this URL results in a 404 again:  "The requested resource (/register-plugin) is not available."

0 Kudos
ChrisBedford
VMware Employee
VMware Employee

Hello,

The URL with which to register the Big Data Extensions plug-in should be unchanged. Aside from receiving a 404 error, are there any other error messages?

One possible problem could be if your browser is using a proxy, and you're using the IP address of the server. If you want to use the server IP address to access the vSphere Web Client and your browser uses a proxy, add the server IP address to the list of proxy exceptions.

I hope that helps. Please let us know if you continue to have issues.

Kind Regards,

Chris Bedford

0 Kudos
a_landsidel
Contributor
Contributor

There is no proxy involved, the only error during the process is the 404 when trying to perform the plugin installation step.

The only troublesome spot I had during installation was step 10 in the PDF.  I am using vSphere 5.1.0 on a 6-socket enterprise plus cluster, and the instructions mention something about the SSO URL -- I was not prompted for this at any time during the OVA deployment however so I am not sure if I was supposed to enter it somewhere.

The management VM in the vApp looks normal and I did not see any errors on the console during bootup.

0 Kudos
ChrisBedford
VMware Employee
VMware Employee

Hello,

I'm going to send an e-mail to the team at large regarding the issue you're experiencing, but just out of curiosity, could you try connecting using SSL? In other words, use https://

For example:  https://management-server-ip-address:8080/register-plugin

Thanks,

Chris

0 Kudos
a_landsidel
Contributor
Contributor

Thanks Chris.

Trying with SSL just results in an error about the packet being invalid/too large -- standard browser error message when you try to connect via SSL on a non-SSL enabled port.

The error I'm seeing is a standard Tomcat error indicating the webapp isn't there -- like it's been renamed, or wasn't installed.

Going to port 80 which, I believe, is supposed to be the normal management interface once everything is up and running just displays an Apache2 test page.  "This page is used to test the proper operation of the Apache HTTP server after it has been installed. If you can read this page it means that the Apache HTTP server installed at this site is working properly." and then some thanks for installing/using apache2/centos stuff.  This may be normal behavior.

The steps I've taken so far are really dead simple.

1. Install the OVA

2. During install, specify static IP options for the management server.

3. Power on the vApp (which powers up the management VM)

4. Navigate to the plugin registration page

I logged in on the console and checked the log in --------------- and it says, in part:

registering serengeti server as vc ext service

DEBUG VcExtension:92 - Registering extension vService at: https://my.vcenter.server/vsm/extensionService ExtensionKey: com.vmware.serengeti.b238f66a

INFO VcExtension:135 - Response Header: null :HTTP/1.1 200 OK

...

DEBUG VcExtension:148 - Successfully registered

etc.  After that it properly shows the datastore, vApp name, cluster name, etc -- so it looks like it's working properly.

The error log says that the vhost and user already exist for 'chef' and that apache was unable to determine the server name.  I'm going to add a static DNS entry for the server and see if that helps, though I don't remember anything in the documentation saying that the management server needed to have a host record in DNS.

0 Kudos
a_landsidel
Contributor
Contributor

FYI adding a host record to the DNS server for the IP assigned to the management server didn't help.  Full error is:

HTTP Status 404 - /register-plugin


type Status report

message /register-plugin

description The requested resource (/register-plugin) is not available.


Apache Tomcat/6.0.32

0 Kudos
admin
Immortal
Immortal

The error show that the register applicaton has not been loaded by tomcat correctly.

Could you have a look with the tomcat log at /opt/serengeti/tomcat6/logs/catalina.out in Serengeti managment server, you can have a check whether it has some error under the message "INFO: Deploying web application directory register-plugin"

0 Kudos
Yonghua
Contributor
Contributor

Not sure if you're seeing error message in the first boot log. If the boot up has any problem, it probably cause the registration deployment error. If you can post the log files under /opt/serengeti/logs directory together with the tomcat log /opt/serengeti/tomcat6/logs/catalina.out, as Zach said, it would be helpful to figure out the problem.

thanks

Emma

0 Kudos
a_landsidel
Contributor
Contributor

chenz, the register-plugin app isn't mentioned in that logfile at all; /serengeti and /datadirector are the only ones mentioned.  I tried /serengeti/register-plugin and /datadirector/register-plugin and no dice.

Yonghua, there weren't any errors during boot, just a warning about some chef option being deprecated.

I searched the serengeti logs directory and the tomcat logs directory for 'register' and only came up with a few hits, ignoring the Hibernate thing that isn't found in serengeti.log.

/opt/serengeti/logs/serengeti-firstboot.log: registering serengeti server as vc ext service

/opt/serengeti/logs/serengeti-firstboot.log:[21-Aug-2013 18:15:35] DEBUG VcExtension:92 - Registering extension vService at: https://vcenter.concord.local/vsm/extensionService ExtensionKey: com.vmware.serengeti.b238f66a

/opt/serengeti/logs/serengeti-firstboot.log:[21-Aug-2013 18:15:35] DEBUG VcExtension:140 - Successfully registered

Searching /opt/serengeti/tomcat6/logs/ results in 'SEVERE' notices that "The web application [/serengeti] registered the JDBC driver but failed to unregister it when the web application was stopped.  To prevent a memory leak, the JDBC Driver has been forcibly unregistered."  The same notice appears for /datadirector.

The word 'register' does not appear elsewhere in any file in either directory

Just to make sure I didn't stumble across some old page, The OVA I have is "VMware-Serengeti-0.8.0.0-1063738_OVF10.ova"

0 Kudos
a_landsidel
Contributor
Contributor

Chris and others, I screwed up.  It turns out I am using the wrong OVA.  I have the Serengeti 0.8 vApp, when in reality I need the BDE 1.0 vApp.  Figures!  Thanks to all who tried to assist.

0 Kudos
ChrisBedford
VMware Employee
VMware Employee

Hello,

We're just glad you found the solution!

Please let us know if you encounter any additional problems. We are happy to help you be successful!

Please also let us know what you think of Big Data Extensions. What would you like to see improved, and what features or enhancements would you like to see added in the future?

Kind Regards,

Chris Bedford

0 Kudos