sbsbcatubig
Contributor
Contributor

BDE fails to add resources after fresh install

Jump to solution

Hey Guys,

Having some trouble with BDE 2.1 and getting serengeti working. It looks like VHM is having problems connecting to vcenter. Here is the exact error.

Location: /opt/serengeti/logs/vhm.log

Message: 2015 Apr 21 18:24:21.671 ** VHM: connection to vCenter failed (class java.io.FileNotFoundException): /tmp/keyStore (No such file or directory)

2015 Apr 21 18:24:21.672 ** VHM: could not obtain vCenter connection through any protocol

2015 Apr 21 18:24:21.672    VHM: temporarily lost connection to vCenter

Location: /opt/serengeti/logs/serengeti-boot.log

Message: E, [2015-04-21T18:22:39.991825 #8536] ERROR -- : Serengeti Web Service failed to generate uuid in serengeti.properties file in 5 minutes.     It's probably a VC connection issue, please check /opt/serengeti/logs/serengeti.log

Serengeti.log does not spit out anything useful.


Has anyone seen this before?


Thanks!

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
jessehuvmw
Enthusiast
Enthusiast

BDE vApp must be deployed in the top level resource pool under a vCenter cluster, otherwise you will see the error log. Please kindly check it.

Thanks.

Cheers, Jesse Hu

View solution in original post

0 Kudos
2 Replies
gguanglu
VMware Employee
VMware Employee

Hello,

VHM is not in active maintenance mode in BDE v2.1, considering that all major Hadoop distro vendors already moved to Hadoop/MapReduce 2.0 (YARN) and VHM doesn't work well with it yet. So we didn't advocate its function with YARN either.

Thanks,

Gavin

0 Kudos
jessehuvmw
Enthusiast
Enthusiast

BDE vApp must be deployed in the top level resource pool under a vCenter cluster, otherwise you will see the error log. Please kindly check it.

Thanks.

Cheers, Jesse Hu
0 Kudos