redsand007
Contributor
Contributor

vRO 8 - REST Call Receiving handshake warning: unrecognized_name error

Jump to solution

When making a basic rest call using a transient rest server in vRO I am receiving the following error:

Cannot execute the request: ; received handshake warning: unrecognized_name

 

I am able to make the same exact call (copy and paste code) to same rest server in vRO7 w/o an error so it seems like something new in vRO8.

Looking up the error I see non vRO solutions that say apply the following setting change:

JVM_SUPPORT_RECOMMENDED_ARGS="-Djsse.enableSNIExtension=false" 

Is there a vRO setting equivalent that can be changed or is there another solution to this problem?

0 Kudos
1 Solution

Accepted Solutions
pguinan
Contributor
Contributor

Hi, had the same problem.

This is the fix applied to bypass SNI validation (Ideally not recommended) by setting option for Java in vRO 8 -

1. Need to update /opt/charts/vco/templates/deployment.yaml (If you want to create a backup of this file do in another folder)

2. Within deployment.yaml, please look for JVM_OPTS in the section of  "- name: vco-server-app" there is another section for controlcenter which also got JVM_OPTS  you won't need to edit this.

3. At JVM_OPTS  you can add the option "-Djsse.enableSNIExtension=false" (tested it after the line with port 8280)

4. On the next run of "/opt/scripts/deploy.sh" vRO will be deployed with the new option

Good luck

 

View solution in original post

1 Reply
pguinan
Contributor
Contributor

Hi, had the same problem.

This is the fix applied to bypass SNI validation (Ideally not recommended) by setting option for Java in vRO 8 -

1. Need to update /opt/charts/vco/templates/deployment.yaml (If you want to create a backup of this file do in another folder)

2. Within deployment.yaml, please look for JVM_OPTS in the section of  "- name: vco-server-app" there is another section for controlcenter which also got JVM_OPTS  you won't need to edit this.

3. At JVM_OPTS  you can add the option "-Djsse.enableSNIExtension=false" (tested it after the line with port 8280)

4. On the next run of "/opt/scripts/deploy.sh" vRO will be deployed with the new option

Good luck

 

View solution in original post