V00Z11
Enthusiast
Enthusiast

vRO 8.1 data grid element with external source not showing actions

Jump to solution

I’d like to use the data grid element for a user interaction. The data grid should use an action as external source. There is a description in the vRA documentation on how to use the data grid element (https://docs.vmware.com/en/vRealize-Automation/8.0/Using-and-Managing-Service-Broker/GUID-5A7110FE-A...)

But I can't get it to work because it doesn’t find any actions. What I tried so far is this.

Create simple action which returns an array of properties.

1.png

Create a workflow with an output variable of type Array/Properties.

pastedImage_1.png

Place a user interaction on the schema and link it to the output variable.

pastedImage_2.png

On the user interaction tab set the columns matching the output of the action and try to select the action under external source. It is not returning any actions for selection.

pastedImage_3.png

It this even supposed to work in vRO alone or is this a bug or am I doing something wrong?

1 Solution

Accepted Solutions
V00Z11
Enthusiast
Enthusiast
0 Kudos
17 Replies
inevp
Enthusiast
Enthusiast

I'm guessing you've hit a bug that has been fixed as I'm unable to reproduce it. What exact vRO build are you running?

0 Kudos
V00Z11
Enthusiast
Enthusiast

Thanks for looking into this. I'm on 8.1.0 (15962410).

0 Kudos
stdrv
VMware Employee
VMware Employee

This is a known issue for 8.1, and is logged in the release notes.

  • Properties and Array/Properties types cannot have default external source values.

As a workaround you can try to use a composite type.

0 Kudos
V00Z11
Enthusiast
Enthusiast

I just noticed the slight difference of the build versions. The release notes state that 15995344 is the lastest. I picked the vRO 8.1 OVA up on release day. It looks like it got repleaced with a newer build after GA.

0 Kudos
V00Z11
Enthusiast
Enthusiast

The UI states the build 15962410 but vracli version says I'm already on Version - 8.1.0.9326 Build 15995344.

pastedImage_6.png

root@xxxxxxx[ ~ ]# vracli version

Version - 8.1.0.9326 Build 15995344

Description - VMware vRealize Orchestrator Appliance 8.1.0

I tried upgrading nevertheless as stated in Upgrade a Standalone or Clustered vRealize Orchestrator 8.0.1 Deployment but it says it's not affected.

root@xxxxxxx[ ~ ]# vracli upgrade exec -y --profile lcm --repo cdrom://

Loading update bootstrap.

Update bootstrap is not available. Continuing with current configuration.

Loading configuration profile.

Saving configuration parameters

Running procedures in background...

.......................................

Upgrade procedure started in background.

During upgrade, downtime of the services and restarts of the VAs are expected.

Use 'vracli upgrade status --follow' to monitor the progress.

... Preparing for upgrade .....................................

...............................................................

Running health check before upgrade for nodes and pods.

Health check before upgrade for nodes and pods passed successfully.

...............................................................

Configuring SSH channels.

SSH channels configured successfully.

...............................................................

Checking version of current platform and services.

Version check of current platform and services passed successfully.

...............................................................

Running infrastructure health check before upgrade.

Infrastructure health check before upgrade passed successfully.

...............................................................

Configuring upgrade repository.

Upgrade repository configuration failed.

... Upgrade preparation failed. The system is unaffected. ...

Upgrade Report

Summary

-------------------------------------------------------------------------------------

Date:                   Fri May  8 07:20:12 UTC 2020

Duration:               1 minutes

Result:                 Preparation Error

Description:            Preparation for upgrade has discovered problems. Review to error report below to correct the problems and try again. The services remained in working order.

Reference

-------------------------------------------------------------------------------------

Logs:                   /var/log/vmware/prelude

Backup:                 /data/restorepoint

Runtime:                /var/vmware/prelude/upgrade

Some directories might not exist.

Errors

-------------------------------------------------------------------------------------

No new version is available in the repository.

Remote command failed: /opt/scripts/upgrade/vami-config-repo.sh 'local' at host: xxxxxxx

Remote command failed: /opt/scripts/upgrade/vami-config-repo.sh 'local' at host: xxxxxxx

Accessing update repository failed on one or more nodes.

0 Kudos
inevp
Enthusiast
Enthusiast

Sorry, but after looking into the release notes I saw that even though I can select the action as an external source it doesn't populate the right values in the form. The issue has been fixed in the development branch and will not be present in 8.2 but has not been backported to 8.1 as of yet. We'll try to backport the fix so that it is available in the 8.1 HF patch scheduled for June.

0 Kudos
inevp
Enthusiast
Enthusiast

The build number that you get from vracli (15995344) is the build of the appliance and the build you see in the UI (15962410) is the build of the vRO. These two are the same release.

0 Kudos
V00Z11
Enthusiast
Enthusiast

Thanks for the infos. Should I open a SR and refer to this issue so it gets prioritized for backporting to the next 8.1 HF patch?

0 Kudos
inevp
Enthusiast
Enthusiast

No need, we already started backporting it Smiley Happy

dweber
Contributor
Contributor

Hello,

When can we expect the backported to be available ? or the new 8.2 version to be available ?

Thx you

0 Kudos
inevp
Enthusiast
Enthusiast

The fix has been backported and should be available in the 8.1 patch that is currently scheduled for GA in June.

0 Kudos
V00Z11
Enthusiast
Enthusiast

inevp​ HF1 for vRA 8.1 has been released, which includes a couple of vRO fixes. Do you have any idea when HF1 for standalone vRO 8.1 will be released?

0 Kudos
inevp
Enthusiast
Enthusiast

A HF release including the same fixes should be available for standalone vRO soon (maybe next week, but I'm not 100%), not sure why it didn't get released at the same time as vRA though.

0 Kudos
V00Z11
Enthusiast
Enthusiast

I applied Patch 1 today but I can't get it to work. I still don't see any actions.

VMware vRealize Orchestrator 8.1.0 Patch 1 Release Notes

As mentioned in the releases notes I tried using the composite type for both the action and the input form but it won't work. I'll open a SR next week and will provide a recording of the steps im doing.

0 Kudos
dweber
Contributor
Contributor

Hello,

Where did you get the patch for download ?

In Vmware download section, I only see the latest release to be 15995344 (no trace of the patch1 29 June 2020 | Build 16419934)

Thx

  • VMware vRealize Orchestrator 8.1.0 Update Repository
  • File size: 2.69 GB
  • File type: iso
Name:O11N_VA-8.1.0.9326-15995344-updaterepo.iso
Release Date: 2020-04-14
Build Number: 15995344

I tried the "check update" in the VAMI interface but as I expected, I can't make it to work even if I set all proxy settings correctly on the Network>Proxy tab.

No direct internet is really a pain sometimes.

See you

0 Kudos
V00Z11
Enthusiast
Enthusiast

You can download the patch here:

https://my.vmware.com/group/vmware/patch

V00Z11
Enthusiast
Enthusiast
0 Kudos