Czernobog
Expert
Expert

vRO 7.3 Multi Node - cannot query workflows

I'm trying to use the vRA 7.3 embedded vRO instance as the master and a stand-alone vRO 7.3 as a slave.

The binding is done with a user account that has admin rights on the remote instance, the session is shared.

Adding the server works fine, however I cannot query the remote workflows and in consequence, cannot create proxy workflows. Querying the remote vRO plugins works, I can search for VMs, query the NSX plugin etc, just querying the vRO inventory for workflows, actions and other objects is not producing results:

pastedImage_0.png

Am I doing something wrong here or should I open a SR?

Tags (2)
0 Kudos
2 Replies
iiliev
VMware Employee
VMware Employee

Anything suspicious in vRO logs (local + remote) ?

Czernobog
Expert
Expert

The slave instance does indeed log an error regarding permissions:

2017-10-18 13:45:45.370+0000 [https-jsse-nio-0.0.0.0-8281-exec-8] ERROR {} [DefaultVerifier] User LDAP-USER-["accountname"] - corp\accountname doesn"t have necessary rights "View", required to execute operation on (WorkflowCategory, 8adfc0b25e3d3870015e3d3982910009).

What I have noticed is, that the account is not the one I am currently using. During initial configuration I have erroneously used an account that had no admin rights. I have changed it using the "Update an Orchestrator sever" workflow, however the change did not seem to be executed properly.

Deleting the Orechestrator server and Adding it again with the correct account resolved the issue.

0 Kudos