BillSkulley
Contributor
Contributor

vCO and vCD: Networks

So this might be simple, but my forehead is sufficiently bruised that similar bruises to my ego are acceptable.

I have a vCloud deployment which is relatively simple with direct external networks for each org vDC.  When I run the out of the box "instantiate a vapp template" workflow from vCO the vapp is instantiated with no vApp or VM networks.  This is easily correctable via the vCD WebUI, but I've yet to hit on a vCO method to correct this.

The "Wire a virtual machine network" workflow doesn't work because the vApp has no networks.  "Add a vApp network" wants to create a new network rather than "add" an existing network to the vApp.  The publicly available PSO scripts appear to do the same.

I've spent some time trying to code my own but am not at all clear what the process is to update the vApp with an existing network that I can then turn around and "connect" the vms to.  I've trolled all over the vCO API browser but haven't found much in the way of enlightenment so far though I've managed to become very confused on the relation between networkconfig and networkconnection, if any...

It might very well be that I'm approaching things all wrong.  Any pointers would be greatly appreciated, particularly in the area of "reconfiguring" network settings to connect to existing networks via vCO.

0 Kudos
3 Replies
cdecanini_
VMware Employee
VMware Employee

You need to add a vApp network first (even if it creates one). I do not have my examples at hand here. I may not be able to post before tomorrow.

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vCenter Orchestrator tips and tutorials - @vCOTeam on Twitter
BillSkulley
Contributor
Contributor

I went and took a closer look at the PSO scripts since "Add an Org VDC Network to a vApp" from com.vmware.coe.vcd51.import.vCenterVMs.package is named exactly what I was trying to accomplish.  Out of the box it had a validation error on the "enabled" boolean parameter but once I set that to "true" it worked.  I was then able to use the "Wire a virtual machine network" flow to connect the vm to the orgvdc network.

Thanks!

0 Kudos
cdecanini_
VMware Employee
VMware Employee

Sorry for not getting back to you earlier. I wrote pthis package but I forgot it contained the code example . Shame on me for the validation error :smileyblush:

Christophe.

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vCenter Orchestrator tips and tutorials - @vCOTeam on Twitter
0 Kudos