hurdle
Enthusiast
Enthusiast

unable to start a published web view

I am in the process of setting up orchestrator in a lab

I have follwed the guide but I don't seem to be able to start a web view.

It says click on General and you should see a web view link, but I don't

I did confirm them vCO web Operator plugin was installed

If I click on General\Advanced I set my web view directory to c:\web view

and used an admin account for the web login and password

even restarted the server.

Can someone help me as to what stupid thing I am missing

0 Kudos
2 Replies
tschoergez
Leadership
Leadership

Hi!

Do you want to develop webviews? I so, you set the webview-development-directory in the General/Advanced-TAb in configuration and activate the checkbox for webview developer mode.

But than you have to export the content of the weboperator webviews to the above configured directory.

Details should be in the Orchestrator developer guide at the "developing webviews" section.

IF you dont want to develop webviews, deactivate the webview-dev-mode in General/Advanced.

In both cases you have to publish the webview, which means in vCO-Client go to the webviews-bar, rightclick on the weboperator-webview and "publish". you will see a small green symbol when the webview is published.

regards,

Joerg

www.vcoportal.de - Orchestrate. Your Cloud.
0 Kudos
cdecanini_
VMware Employee
VMware Employee

The problem is certainly that you have followed the steps to enable Web view development mode. This allows to store the webview localy in a directory so you do not have to import / publish every time you change something. You will need to disable that option to use the webview.

On top of my head here are the steps to make sure a webview is published:

Web view plublication:

  • Open the vCO Client
  • Click ont he web view tab
  • Right click on the web-view you want to publish and select "publish" in the contextual menu.

vCO configuration:

  1. Check the vCO configuration service is started.
  2. In a browser enter the following url: http://localhost:8282/ (replace localhost with your vCO hostname or IP)
  3. In the General tab go to the advanced one. Check "Enable Web view development mode" is not checked. If it is uncheck it.
  4. In the network tab. Check what is used for http port (default is 8080).

Check if your web views are published :

  • In a browser enter the following url: http://localhost:8080/vmo/ (replace localhost with your vCO hostname or IP, replace port number by the one in step 4)
If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vCenter Orchestrator tips and tutorials - @vCOTeam on Twitter
0 Kudos