yeayu
Enthusiast
Enthusiast

run program in guest fails

Jump to solution

Hello all,

I am performing some testing with vCO 5.5 before putting it into my company's environment.

Although I can run some workflows successfully (create, clone VMs and things like that), I am strugling trying to run a program in a guest.

As a newbie, I am still using vCO workflows out of the box (no modifications performed yet) so i don't know why the workflow called "run program in guest" fails...

I am using this config:

user: test

password: password1

vm: vm-xp (guest powered on and selected through vCO GUI)

interactive session: yes

program path: C:\windows\notepad.exe

arguments: N/A

working directory: C:\windows

environment: N/A

i have tried with different configurations, but always the same result and not useful errors logged...

Can anyone give me a hand?

Thanks in advance

1 Solution

Accepted Solutions
yeayu
Enthusiast
Enthusiast

Due to my ignorance :smileysilly:, I installed VIX plugin (obsolete as far as i know) to be able to interact with the guests.

After checking the server.log, I found out that there was some errors trying to calling the VIX plugin, so I uninstalled the plugin and everything works now.

Many thanks for all your help.

Regards,

View solution in original post

0 Kudos
7 Replies
abhilashhb
VMware Employee
VMware Employee

Without Interactive session ticked?

------------------------------------------------------------------------------------------------------------------------------------ If you find this or any other answer useful please mark the answer as correct or helpful. Abhilash B | Blog : http://vpirate.in | Twitter : @abhilashhb | LinkedIn : https://www.linkedin.com/in/abhilashhb/ |
0 Kudos
yeayu
Enthusiast
Enthusiast

Hello,

Thanks for your reply, but I am afraid the workflow keeps failing whatever that option is set to.

is there any way I can see where is it failing?

0 Kudos
iiliev
VMware Employee
VMware Employee

Try with the following parameters:

interactive session:  Yes

program path:   c:\windows\system32\cmd.exe

arguments:     /c C:\Windows\system32\notepad.exe

Hope this helps.

0 Kudos
yeayu
Enthusiast
Enthusiast

Thanks for your attempt, but still no joy...

I have tried also on a Win7 (fresh and UAC disabled) but the same result.

what could i add to the workflow to troubleshoot? any log i can see some info?

Any help is appreciated.

Regards.

0 Kudos
iiliev
VMware Employee
VMware Employee

Tried it in my test environment (Win 2008 R2); seems to work fine.

You can check for some info in the vCO server log at {VCO_INSTALL_DIR}\app-server\logs\server.log

yeayu
Enthusiast
Enthusiast

Due to my ignorance :smileysilly:, I installed VIX plugin (obsolete as far as i know) to be able to interact with the guests.

After checking the server.log, I found out that there was some errors trying to calling the VIX plugin, so I uninstalled the plugin and everything works now.

Many thanks for all your help.

Regards,

View solution in original post

0 Kudos
Burke-
VMware Employee
VMware Employee

FYI - I have recommended that the VIX plug-in be removed from the FLINGs page as it has been deprecated for quite some time now and can cause all kinds of problems such as the one you recently experienced.

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vRealize Orchestrator tips and tutorials - @TechnicalValues on Twitter