virgilwall
Contributor
Contributor

package fails to install on vCO 4.1.3, OK on 4.1.1 & 5.1

Has anyone seen a message like this installing a package on vCO 4.1.3?  The package installs fine on 4.1.1 and 5.1, but fails on 4.1.3.

ERROR [ModulesFactory] Unable to perform plug-in installation 'AdcVCOPlugin',
reason : (plug-in - AdcVCOPlugin) Unable to install package 'packages/com.radware.adc.package' ,
reason : ch.dunes.model.dunes.ScriptModuleCategory cannot be cast to ch.dunes.model.workflow.Workflow
It doesn't tell me what the offending workflow is.  It is strange that it works on both an earlier version and a later version.
0 Kudos
2 Replies
DavidPatterson
Contributor
Contributor

I am the person who posted this yesterday.  I was logged in as a coworker when posting this originally.

If anyone can help, I'd appreciate it.  I even tried exporting some of the actions that I thought were ok and importing them into a new package in 4.1.3.  After exporting it, wiping my 4.1.3 and reinstalling it, I get the same error.

0 Kudos
cdecanini_
VMware Employee
VMware Employee

I would definitely recommend opening a support request at VMware global support services since very few people are on 4.1.3 here.

Christophe.

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vCenter Orchestrator tips and tutorials - @vCOTeam on Twitter
0 Kudos