malorr
Contributor
Contributor

VMO communication with VC

Jump to solution

Hi,

There seems to be a few posts on this subject but nothings that helps so I think I'm missing something. I configure my VC connection in Orchestrator to use the VC admin user with a "Session per user" , I have installed the certificate from the VC server and I can test the connection and all looks good and it goes green in orchestrator but when I try and register anything or import anything in LCM I dont see anything below the VC when I browse for a resource. In addition in orchestrator I get some permission erors shown below, I am using the LCM appliance out thebox so no changes to the LDAP schema and I didn't think I needed to as the admin user has all the required privildges! any thoughs?

009-04-24 14:28:55.256+0100 WARN createPropertyFilter() --> Unable to create the filter xisFault faultCode: ServerFaultCode faultSubcode: faultString: The session is not authenticated. faultActor: faultNode: faultDetail: NoPermissionFault:<object type="PropertyCollector">propertyCollector</object><privilegeId>System.View</privilegeId>he session is not authenticated.

2009-04-24 14:28:55.258+0100 ERROR getProperty() --> Property 'name' does not exist

Environment

LCM 1.0.1

VC 2.5 update 3

thanks

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
admin
Immortal
Immortal

Hi malorr,

For LCM, we recommend you use the Shared session configuration for VC connection.

The warn log tells you the user don't have persmissions...

The error log tells you VMO cannot retrieve the name of the folder. or basically all properties of the folder. maybe because you don't have persmissions..

View solution in original post

0 Kudos
4 Replies
Burke-
VMware Employee
VMware Employee

It is sometimes required to restart the appliance after adding the VC server... have you restarted it? If not, please do so and report back.

Additionally, I've just re-read back through your post and you state that you set "Session per user".. this means that the credentials used to login to LCM are passed through to your VirtualCenter server... this means that if you're using the built-in groups/users in the appliance, you "probably" don't have a user such as "lcmadmin" or "lcmuser" on your VirtualCenter server. I would recommend setting that connection to shared session, using your VirtualCenter Administrator account & pw.

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vRealize Orchestrator tips and tutorials - @TechnicalValues on Twitter
admin
Immortal
Immortal

Moved to VMware Orchestrator community.

Robert Dell'Immagine, Director of VMware Communities

0 Kudos
admin
Immortal
Immortal

Hi malorr,

For LCM, we recommend you use the Shared session configuration for VC connection.

The warn log tells you the user don't have persmissions...

The error log tells you VMO cannot retrieve the name of the folder. or basically all properties of the folder. maybe because you don't have persmissions..

View solution in original post

0 Kudos
malorr
Contributor
Contributor

Hi cedric,

that was the case, I hadn't assigned privlidges to the datacenter level, all working now

thanks

malcolm

0 Kudos