anualways1
Contributor
Contributor

Unable to tunnel through proxy. Proxy returns "HTTP/1.1 407 Proxy Authorization Required" (Workflow:Manage SSL certificates / Get URL certificates (item0)#14)

Jump to solution

Proxy with credentials are required in our environment for access to Service Now instance. But while integrating vRO and Service Now using "ADD a SOAP Host" workflow, we don't have an option for credentials with proxy.

What all options we can have for the same.

0 Kudos
1 Solution

Accepted Solutions
iiliev
VMware Employee
VMware Employee

Hi,

Unfortunately, the current SOAP plug-in doesn't support proxy authentication (unlike REST plug-in) and there are no immediate plans to add it.

Feel free to file a feature/support request so it can be prioritized for some future release.

View solution in original post

0 Kudos
3 Replies
iiliev
VMware Employee
VMware Employee

Hi,

Unfortunately, the current SOAP plug-in doesn't support proxy authentication (unlike REST plug-in) and there are no immediate plans to add it.

Feel free to file a feature/support request so it can be prioritized for some future release.

View solution in original post

0 Kudos
anualways1
Contributor
Contributor

Hi Ilian Iliev,

Thanks for answering. Could you please tell us how it can be done through REST as by default workflow doesn't have the proxy credentials options while adding it as REST Host.

Can we modify the existing workflow and add the required parameters for Proxy credentials or is there any other way where we can put our credentials and it can work.

0 Kudos
iiliev
VMware Employee
VMware Employee

Hmm, could you check what is the version of the workflow 'Add a REST host'? In my environment, when I select the option to use a proxy and select 'Basic' as proxy authentication type, a new page 'Proxy Credentials' appears where I can provide user/password.

0 Kudos