Highlighted
Contributor
Contributor

TypeError: Cannot call method "getAttribute" of null

We have an odd issue where we have a workflow that runs and creates and AD group with the $, but it fails to rename the group with the message below.  If I start the group name with A-L it works, but anything above that failes.  We are at vrealize orchestrator 7.3 and AD plugin is 3.0.5.  I have tested on a different domain and it works fine.  So not sure if it is a AD issue. 

Error in (Workflow:Create AD Group and add user / Set Group Name Consistently (item12)#55024) TypeError: Cannot call method "getAttribute" of null

0 Kudos
4 Replies
Highlighted
VMware Employee
VMware Employee

Can you share the workflow and the exact steps you do to reproduce the error?

0 Kudos
Highlighted
Contributor
Contributor

It fails on the Set Group Name Consistently step.  It works when the group name starts with A-L.

0 Kudos
Highlighted
VMware Employee
VMware Employee

In my environment, it fails at a later stage, on item 'Recursive user Search'. But as the code is written, it won't work work for sure, due to the line

if (userPrincipalName = strUserName) {

Where does userPrincipalName comes from? Also, why do you use an assignment instead of comparison?

0 Kudos
Highlighted
Contributor
Contributor

Looks
like we found our issue with the AD and a limit of 1000 per page.  It
looks like the AD plugin 3.0 and above has a code you can run.  Would you
be able to tell us how we can modify the workflow to work with that fix?

https://communities.vmware.com/thread/564387

0 Kudos