Highlighted
Enthusiast
Enthusiast

Task scheduler

Jump to solution

I am a bit confused as to how task scheduler functions when appliance is set to UTC but client uses a different time zone (ET in my case). Everything in the client is indicative that it will use local time but the job that's set to reoccur weekly on certain days would kick off on UTC time.

However, if I use no re-occurrence the job initiates on my local time.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
VMware Employee
VMware Employee

I have just double checked and fix is not included in 7.3 but will be included in 7.4.

View solution in original post

0 Kudos
3 Replies
Highlighted
VMware Employee
VMware Employee

Similar issue got reported recently and fix was implemented in vRO 7.3

Here is  another thread for similar issue Scheduled Workflow Never Runs

If I remember correctly issue was that in vRO Smart client in some places in UI was showing next execution time based on server  timezone or UTC and on some of them based on local client timezone.

Fix introduced was  vRO server to use server timezone when running the scheduled task and vRO Smart client to convert scheduled task next execution times in local client time when visualizing it.

So when creating patterns for execution they will be applied based on server timezone and vRO client will calculate them based on server timezone and when showing next execution vRO smart client will calculate  it based on server timezone and  then will convert it to local time before showing it.

Smiley Happy

0 Kudos
Highlighted
Enthusiast
Enthusiast

Since 2015??!?!? Smiley Happy

Yes, that sounds like what I am encountering, currently on 7.2.1 in prod. I'll check it out on 7.3 Thanks for the tip.

0 Kudos
Highlighted
VMware Employee
VMware Employee

I have just double checked and fix is not included in 7.3 but will be included in 7.4.

View solution in original post

0 Kudos