v_potnis2001
Contributor
Contributor

Stuck with SQL server configuration

I have SQL server running and I can login using user, password. Now the same user, password combo doesn't work for Orchestrator. Any reasons why?

What should be the hostname or IP?

0 Kudos
9 Replies
admin
Immortal
Immortal

Is SQL configured to only accept Windows auth or does it also have simple auth enabled?

0 Kudos
v_potnis2001
Contributor
Contributor

Yes, its been configured that way. Is there a doc somewhere to help users with this configuration.

0 Kudos
Windspirit
Enthusiast
Enthusiast

- The SQL browser service must be running

- fill Domain field in ONLY if you use a domain and want to use the Windows auth, if you leave it empty the SQL auth will be used.

Whats the erro message you getting?

0 Kudos
admin
Immortal
Immortal

The Orchestrator docs are loccated here: http://www.vmware.com/support/pubs/orchestrator_pubs.html

The install and config guide should help you through it. Certainly let us know if you are still having issues.

0 Kudos
a_p_
Leadership
Leadership

I had the same issue with SQL Express 2005.

Going through the SQL-Server configuration utility, I saw that only the dynamic port was set, the fixed Port was empty. So I edited the fixed port to be 1433, restarted SQL-Express and everything worked fine.

Hope this helps.

0 Kudos
v_potnis2001
Contributor
Contributor

Thanks, let me try this and get back.

0 Kudos
admin
Immortal
Immortal

Yes, and by the way, SQL Express don't enable TCP/IP out of the box: you have to manually enable it.

vCO always use TCP/IP connection, even when the server is localhost.

0 Kudos
CarletonStudent
Contributor
Contributor

I'm having the same challenges in terms of connecting to the sql server. This is the error I get:

"Cannot connect to jdbc:jtds:sqlserver://vsphere:1433/;domain=LABNETWORK. Connection error was: Network error IOException: Connection refused: connect"

I made sure that the SQL Server database and SQL browser both have TCP/IP enabled and restarted both services.

Tx

0 Kudos
admin
Immortal
Immortal

You have to open mutliple ports in your Server firewall (SQL Server firewall). You should just try if it's a firewall issue by shutting it down for a short time.

The ports you'll need are the one from the SQL Server and the one from the SQL Browser

0 Kudos