Highlighted
Enthusiast
Enthusiast

Scheduled Workflow Never Runs

Jump to solution

I'm trying to schedule a workflow to run on a schedule.  If I schedule the workflow to run without recurrence, it works fine.  If I schedule it and add recurrence, it doesn't run.  I've tried setting the recurrence to be daily a few minutes from "now".  The general tab shows that the next run will be at the time I specified "today".  Then the time passes by and I click off and back onto the general tab and now it says the next run will be "tomorrow" at the time I specified.  The last run is empty.  No workflow runs showed up,  The only thing I see in the vRO config log file (with debug mode on) is me changing the recurrence setting on the workflow.

If I remove the recurrence setting and set the start of operation to a few minutes in the future, the task runs.

Anyone know what could be going on here?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
VMware Employee
VMware Employee

Sounds like a bug in vRO client code which may happen if the vRO server and vRO client machines are in different time zones.

Lets suppose that vRO server is in Utc and vRO client is in Utc+2, that at the moment it is 20:00 on the client machine (equivalent of 18:00 on server machine), and that you are scheduling the workflow to run at 20:02 (client time, 2 minutes from now)

  • Case 1 - you are scheduling without recurrence. The scheduling code correctly compensates time zones difference and the workflow is scheduled to run at 18:02 server time (2 minutes from now). Everything works as expected.

  • Case 2 - you are scheduling with recurrence. Apparently there is some bug in the scheduling code which doesn't compensate correctly time zones difference and the workflow is scheduled to run at 20:02 server time (2 hours and 2 minutes from now). Obviously, this is not a correct behavior - the workflow is scheduled and will run but not at the time you expect.

You can look at vRO server.log file - there should be some log statements showing the actual schedule time; something like

   Adding task 'workflowname' to schedule [2015-09-07 18:28:31.0]

View solution in original post

0 Kudos
2 Replies
Highlighted
VMware Employee
VMware Employee

Sounds like a bug in vRO client code which may happen if the vRO server and vRO client machines are in different time zones.

Lets suppose that vRO server is in Utc and vRO client is in Utc+2, that at the moment it is 20:00 on the client machine (equivalent of 18:00 on server machine), and that you are scheduling the workflow to run at 20:02 (client time, 2 minutes from now)

  • Case 1 - you are scheduling without recurrence. The scheduling code correctly compensates time zones difference and the workflow is scheduled to run at 18:02 server time (2 minutes from now). Everything works as expected.

  • Case 2 - you are scheduling with recurrence. Apparently there is some bug in the scheduling code which doesn't compensate correctly time zones difference and the workflow is scheduled to run at 20:02 server time (2 hours and 2 minutes from now). Obviously, this is not a correct behavior - the workflow is scheduled and will run but not at the time you expect.

You can look at vRO server.log file - there should be some log statements showing the actual schedule time; something like

   Adding task 'workflowname' to schedule [2015-09-07 18:28:31.0]

View solution in original post

0 Kudos
Highlighted
Enthusiast
Enthusiast

Perceptive.  Yes, this was it.  If I put in the time in UTC it works as expected, even though it shows as CDT in the general tab.  Thanks!

0 Kudos