thechaos
Enthusiast
Enthusiast

SSH error when connecting to an esxi host

Hi all,

i'm using the SSH plugin of the orchestrator for doing some tasks on linux. Now i would like to trigger some tasks on an ESXi host, but the SSH workflow does not work using password and user. On the ESXi host itself i get the following error message:

sshd[44903]: Received disconnect from 10.148.12.88: 3: com.jcraft.jsch.JSchException: Auth fail

Using putty a connection is possible

Any ideas ?

TIA

     Thomas

0 Kudos
3 Replies
dimitrovg
VMware Employee
VMware Employee

I had similar issue. The problem was how the server (the ESXi host in your case) is configured. There are two different types of pass authentication in SSH - one is password and the other is keyboard-interactive. The second should be more secure (as the password is entered from human sitting on the keyboard in the moment it is needed). No matter which of them are enabled on the server putty will work. However the SSH plugin will not work in second case as it accepts only password authentication.

To allow it change in /etc/ssh/sshd_config the line

PasswordAuthentication yes

Then restart the SSH daemon:

/etc/init.d/SSH restart

To check all available authentication methods (from the ESXi host itself) use ssh -v hostname

$ ssh -v localhost

debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug1: Next authentication method: publickey
debug1: Trying private key: /.ssh/id_rsa
debug1: Trying private key: /.ssh/id_dsa
debug1: Next authentication method: keyboard-interactive

Password:

If you cannot change the server settings you can still use public-key authentication.

Hope this helps.

thechaos
Enthusiast
Enthusiast

Hi,

yes it did, thanks

     Thomas

0 Kudos
WOssignorelli
Contributor
Contributor

This one got me too. Although the fix was much easier. 

For your specific Putty session: 

PUTTY Configuration

Category: 
-->Connection
----->Data
Auto-login username: <CLEAR THESE CONTENTS>

0 Kudos