sandy_1234
Enthusiast
Enthusiast

Query on vRO auto-deploy plugin 6.0.3

As per the release notes for vRO auto-deploy plugin 6.0.3 requires requires vCenter Server 6.0.0a

VMware vCenter Orchestrator Plug-In for vSphere Auto Deploy Release Notes

We have our infrastructre having vCenter version 6.0.0 Build 3634794 / vCenter version 6.0.0 Build 3634793. Does the vRO auto-deploy plugin will work for these vCenter builds?

Also what is the difference between vCenter 6.0.0 and vCenter 6.0.0a?

Regards

Sandeep

0 Kudos
8 Replies
iiliev
VMware Employee
VMware Employee

The build numbers you listed seems to point to vCenter 6.0 Update2, which is a newer release than vCenter 6.0.0a.

Usually, the letter after the build number is used to mark some kind of patch release, that happens between GA releases and update releases. As 6.0 Update2 is logically 'after' 6.0.0a, I suppose the plug-in will work.

0 Kudos
sandy_1234
Enthusiast
Enthusiast

As you suggested we could install the Auto-deploy Plugin as you suggested but receiving the below error while adding an Auto-deploy host.

Capture from /var/log/vco/app-server/server.log

2018-02-23 05:50:33.802+0000 [WorkflowExecutorPool-Thread-10] WARN  {xxxx@xxxx.com:Add an Auto Deploy host:8a3e1b8b61c112a30161c1368ef51b59:10858080808080808080808080808080808080800126658240472157fdafc0fce:[10858080808080808080808080808080808080800126658240472157fdafc0fce]} [WorkflowItemTaskRunner] Script execution error on workflow : Add an Auto Deploy host / 'getAutoDeployHostUri'(item7) : java.lang.NullPointerException (Dynamic Script Module name : getAutoDeployHostUri#4)

Please help !!!

Regards

Sandeep

0 Kudos
iiliev
VMware Employee
VMware Employee

This error looks identical to another one reported by a customer half a year ago, which should be resolved with build# 5951676 of the auto-deploy plug-in. I'll try to confirm that this particular build is the recommended one and will upload it here in the community forums, probably tomorrow.

Another possible cause for the error could be an incompatibility between certain Autodeploy and vCenter plug-ins' versions. Could you tell me the exact versions/build numbers of your vRO server and vCenter plug-in?

0 Kudos
sandy_1234
Enthusiast
Enthusiast

Thanks Ilian. I will look forward for your response.

Regards

Sandeep

0 Kudos
iiliev
VMware Employee
VMware Employee

Could you provide the exact versions/build numbers of vRO server and vCenter plug-in that you use?

0 Kudos
sandy_1234
Enthusiast
Enthusiast

Below are the versions we have:

Auto-deploy plugin we use 6.0.3

vCenter we have is 6.0.0 Build is 3634794.

vRO Server is 6.0.3 Build 3000581

Thanks

Sandeep

0 Kudos
iiliev
VMware Employee
VMware Employee

OK, it seems the plug-in build number I suggested in reply# 3 might not work properly with vRO 6.0.3 - it is build against vRO 7 libraries and assumes that vCenter plug-in configuration is stored at a different place than what is used by vCenter plug-in bundled in vRO 6.0.3

I'm not sure what is the right combination of vCenter plug-in and Autodeploy plug-in builds that will work correctly on vRO 6.0.3; will need to check it further.

0 Kudos
sandy_1234
Enthusiast
Enthusiast

Thanks illian for your help !!

Regards

Sandeep

0 Kudos