trailx
Enthusiast
Enthusiast

Orchestrator 5: Create a simple XML document = write not allowed

Hi,

I'm going to be crazy :smileyangry: , I've upgraded my orchestrator 4.2.1 to 5.0 and now when I want to start the WF (sample provided by default)

"Create a simple XML document" , I have always Permission denied on file 'myfile.xml' , write not allowed

It's the same thing with Find element in document (read not allowed).

I 've changed the default password root:vmware maybe that's why it doesn't work but it will be very curious because on my version 4.2.1 with my password, it works very well...

Thank you in advance Smiley Happy

--- If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!
0 Kudos
3 Replies
ChristianWehner
VMware Employee
VMware Employee

Hi,

maybe you tried this but in the documentation there is a section about limited access to the server out of workflows and javascript:

http://pubs.vmware.com/vsphere-50/index.jsp?topic=%2Fcom.vmware.vsphere.vco_administer.doc_42%2FGUID...

Regards,

Chris

trailx
Enthusiast
Enthusiast

Hi Christian,

My "savior" again Smiley Wink  unfortunately even if  I modifed /opt/vmo/app-server/server/vmo/conf/js-io-rights.conf with

+rwx /

Same problem...  I 've rebooted the system. I can't uderstand why it doesn't work "out of the box" :smileyconfused:

--- If you found this information useful, please consider awarding points for "Correct" or "Helpful". Thanks!
0 Kudos
anuragvr
Enthusiast
Enthusiast

I was also facing the same issue but I resolve this at my end.

Follow these steps to resolve the issue

  1. Create folder in VCO server file system at root level
  2. Open js-io-rights.conf configuration file and add  “+rwx /folder-name/”  to add Read, write, and execute permissions for newly created folder.
  3. Now Open VCO configuration application and go to the “Startup options” tab and restart “vCO configuration service” and “vCO Service”.

  Now execute workflow it will work.



--Anurag R

0 Kudos