acavali
Contributor
Contributor

No Workflows showing up in Web View

I have created a custom Workflow for taking snapshots. When I go to the webview and login with my vCO credentials, I do not see any workflows whatsoever. Anyone know how to fix that?

0 Kudos
8 Replies
Burke-
VMware Employee
VMware Employee

We'll need a bit more detail here.. which webview are you using? Have you added your new workflow as an Attribute to your webview, and then referenced that attribute name inside the HTML code of the webview?

Starting at page 298 of the vCenter Orchestrator Developer's guide, there is a tutorial on "Create a Simple Web View Using the Default Template" that may be able to help you along.

Visit me at for vCenter Orchestrator tips and tutorials Smiley Happy

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vRealize Orchestrator tips and tutorials - @TechnicalValues on Twitter
0 Kudos
acavali
Contributor
Contributor

I am using the weboperator view. I thought that was the default. So for every custom workflow, I have to do what you outlined?

0 Kudos
acavali
Contributor
Contributor

To further clarify, I do not see any workflows under the weboperator web view.

0 Kudos
Burke-
VMware Employee
VMware Employee

The WebOperator is an administrative tool allowing for members of your vcoadmins group to launch a workflow through a web interface, taking advantage of better presentation rendering that what is possible in the vCO client. In order to actually see any workflows after logging into the Weboperator, you must be a member of the group you have specified as a your vco admins group. Is your account a member of this group?

My previous notes and guidance were around a custom webview, not the weboperator. If the users who will be executing your custom workflows are members of your vco admins group and they understand which workflows they should and should not execute, then the weboperator interface may be okay for now... however, a custom web interface would likely be more appropriate.

Visit me at for vCenter Orchestrator tips and tutorials Smiley Happy

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vRealize Orchestrator tips and tutorials - @TechnicalValues on Twitter
0 Kudos
acavali
Contributor
Contributor

I am part of the vCO Admin group and still see nothing listed.

As far as the custom interface is concerned, I do agree with you that it is probably better and I am ready to go down that path. I didn't see any tutorials on your site for creating one. Did I miss it, or are there any plans to create one?

Thanks for all of your help on this!

0 Kudos
Burke-
VMware Employee
VMware Employee

I'm not sure why you are not seeing any workflows when you login to the Weboperator if you are a member of your vco admins group.... quite strange... this would take additional resources and time to properly troubleshoot.

As for tutorials, unfortunately my team has been quite busy lately - too busy for a webview tutorial. If/when we do one, it will likely build upon the one from the vCO Developers Guide that I mentioned earlier. The documentation walks you through a basic Webview. That would really be the best place to get started for now.






Visit me at http://www.vcoteam.info for vCenter Orchestrator tips and tutorials Smiley Happy

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vRealize Orchestrator tips and tutorials - @TechnicalValues on Twitter
0 Kudos
acavali
Contributor
Contributor

Burke -

Thanks for the response. I have opened up a case with support to see why I am not seeing them. I will post back their findings.

0 Kudos
acavali
Contributor
Contributor

It turns out that the problem was related to security settings on the browser. I had to add it to be a trusted site before everything would display properly.

Hopefully this helps someone else out!

0 Kudos