cloudyred
Enthusiast
Enthusiast

Dynamic Types Plugin - Import Configuration From Package fails to parse input and validate namespaces

Jump to solution

Hi,

We regularly use DT plugin and having an issue with the ootb Export and Import Configuration From Package.

Seems 100% reproducible with both internal and external vRO though external is our primary use case.

We also have our own namespace to import but can reproduce by creating your own locally and running export / import.

  • Clean vRO 7.6
  • Run Define Namespace workflow and create a namespace eg "TestNameSpace"
  • Run Export Configuration As Package workflow
  • Export the new package created to disk
  • Run the Import Configuration from Package workflow.

pastedImage_3.png

Trying to proceed anyway finds no namespaces and typing a know good namespace generates an error.

Getting to the point in the screenshot above, we see errors in the server.log.

2019-09-03 16:13:41.893+0000 [http-nio-127.0.0.1-8280-exec-9] ERROR {} [VcoFactoryServiceFacadeProxy] ch.dunes.util.DunesServerException: Action 'getAllNamespacesFromConfig' in m

odule 'com.vmware.o11n.plugin.dynamictypes.configuration' failed : java.lang.NullPointerException (unnamed script#1)

....

019-09-03 16:13:48.579+0000 [http-nio-127.0.0.1-8280-exec-4] WARN  {} [ScriptModuleRuntimeServiceImpl] Unable to execute action class ch.dunes.util.DunesServerException: ch.dune

s.ejb.client.VSOInternalServerFactoryClient.extractPackageImportFromFileData([B)Lch/dunes/model/pkg/impexp/PackageImport; (unnamed script#4)

2019-09-03 16:13:48.580+0000 [http-nio-127.0.0.1-8280-exec-4] ERROR {} [VcoFactoryServiceFacadeProxy] ch.dunes.util.DunesServerException: Action 'validateConfigurationPackage' in

module 'com.vmware.o11n.plugin.dynamictypes.configuration' failed : ch.dunes.ejb.client.VSOInternalServerFactoryClient.extractPackageImportFromFileData([B)Lch/dunes/model/pkg/im

pexp/PackageImport; (unnamed script#4)

We have tested with.

vRO 7.6 GA Internal + External

vRO 7.6 External with https://kb.vmware.com/s/article/70629 roll up patch

vRO 7.6 GA External + DT Plugin Version 1.3.2-14238188 from https://communities.vmware.com/docs/DOC-36813

Is there a bug, workaround, etc can others repro?

Cheers,

Red

https://vro2-vip.domain.local:

0 Kudos
1 Solution

Accepted Solutions
cloudyred
Enthusiast
Enthusiast

IlianIliev

After logging an SR which went to PR 2417282.

Resolved in DT1.3.3 if you want to post it.

Cheers,

Red

View solution in original post

0 Kudos
7 Replies
iiliev
VMware Employee
VMware Employee

Hi Red,

Tried your repro steps, and yes, there seems to be some issue with the import.

Will try to investigate this further, but currently the team is focused on wrapping up the upcoming 8.0 release, so it could take some time. If this issue is a blocker for you, consider opening an official support request; this way, it may be prioritized a bit higher.

0 Kudos
cloudyred
Enthusiast
Enthusiast

Thanks Ilian,

Will give GSS a link to this and ask them to file a bug. Thanks for getting back so fast.

We used to just directly import the xml config resource for the DT plugin as part of our package but it didn't allow for other custom namespaces to coexist.

Also the process here was adopted similar to the 7.5 external vRO Upgrade procedure so open to recommendations.

Cheers,

Redmond

0 Kudos
cloudyred
Enthusiast
Enthusiast

IlianIliev

After logging an SR which went to PR 2417282.

Resolved in DT1.3.3 if you want to post it.

Cheers,

Red

0 Kudos
sbhowan09
Contributor
Contributor

Thanks for the update, any idea where DT 1.3.3 can be downloaded?

0 Kudos
iiliev
VMware Employee
VMware Employee
0 Kudos
sbhowan09
Contributor
Contributor

Thank you Ilian

0 Kudos
cloudyred
Enthusiast
Enthusiast

We're facing similar issue on vro 8.0 even with the latest plugin posted here.

Pr 2472536 raised via GSS.

0 Kudos