wallabyfan2
Contributor
Contributor

Configurations -- Exporting with Content

Hello Community -

During the import of a Package with workflows, actions, and scripts, plus configurations, the configurations do not export with content.

All names, types and descriptions import, but not the Values.

Is there a way to export Configurations with Values?

Thank you.

0 Kudos
4 Replies
stuartclements
VMware Employee
VMware Employee

Hello,

When you import configuration elements, the values are not set. See the Developer's Guide, p.60:

"If you create a package containing a workflow, action, policy, or Web view that uses an attribute from a configuration element, Orchestrator automatically includes the configuration element in the package, but not its value. If you import a package containing a configuration element into another Orchestrator server, the configuration element attribute values are not set. You must set the attributes with values appropriate to the server in which you have imported the package. For example, if you create a workflow that requires attribute values that depend on the Orchestrator server on which it runs, setting those attributes in a configuration element allows you to export that workflow so that another Orchestrator server can use it. If you set the server specific attributes directly in the workflow, the workflow might not work if you import it into another server, because it might not find the attribute values it requires. Because the attribute values in an imported

configuration element are not set, you have to set them with values appropriate to the new server. Configuration elements therefore allow you to exchange workflows, actions, policies and Web views between servers more easily."

http://www.vmware.com/pdf/vco_410_developers_guide.pdf

Thanks,

stuart

vCO docs team

0 Kudos
cdecanini_
VMware Employee
VMware Employee

You can export a configuration element with right clicking / export.

You can then import it with right clicking on a configuration element category / import.

If the content of the configuration element is a value it will work, if it is a reference it will only work if it can find an object with the same ID on your other vCO server.

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vCenter Orchestrator tips and tutorials - @vCOTeam on Twitter
0 Kudos
FSvcoe
Enthusiast
Enthusiast

Interesting, I can right click and choose import from the 'Provisioning' folder (not on the element), and it will import/overwrite the package created from another VCO server, but no values are populated.The two servers are at different versions, 4.1.0 vs 4.1.1 but can that be an issue?

I was able to import with values by deleting the configuration element first and then importing.

0 Kudos
cdecanini_
VMware Employee
VMware Employee

Interesting. Maybe there was a mismatch somewhere. I only tested importing existing configuration on the same server to switch from a given environment to another one.

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vCenter Orchestrator tips and tutorials - @vCOTeam on Twitter
0 Kudos