holashh
Enthusiast
Enthusiast

Change name of workflow run

Jump to solution

Hi, I have a question if is way how to rename just started run of workflow, eg. "Add vCenter Server" to "Adding my vCenter"

Thanks

Tags (1)
1 Solution

Accepted Solutions
cdecanini_
VMware Employee
VMware Employee

Here is an old trick of mine that does not involve hacking the DB Smiley Happy

Code snippets : Change the name of a workflow run

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vCenter Orchestrator tips and tutorials - @vCOTeam on Twitter

View solution in original post

5 Replies
iiliev
VMware Employee
VMware Employee

Hi,

Short answer - no way. As you can see in API Explorer, all of the properties of a workflow run object (WorkflowToken) are exposed as read-only attributes.

Of course, you can try some hacks, for example use Database/SQL plug-in and update the name/title of the run directly in the database, but this goes beyond normal usage scenarios and is not supported.

cdecanini_
VMware Employee
VMware Employee

Here is an old trick of mine that does not involve hacking the DB Smiley Happy

Code snippets : Change the name of a workflow run

If my answer resolved or helped you, please mark it as Correct or Helpful to award points. Thank you! Visit http://www.vcoteam.info & http://blogs.vmware.com/orchestrator for vCenter Orchestrator tips and tutorials - @vCOTeam on Twitter

View solution in original post

holashh
Enthusiast
Enthusiast

Ho Chris,

good tip, is #__username usable also in vRO6.0, bcs it is my case and here I can't find out the usage.

BTW can I replace it with any other input variable?

Thanks,

Jan

0 Kudos
holashh
Enthusiast
Enthusiast

Hi Chris,

it is working like a charm, I am blind and can't read your snippet Smiley Happy.

Thank you, it is working pretty well.

Now I am challenging other topic, how this make it alive with multi-node plug-in, from this usage workflow execution is started with same name as parent workflow, if I started it manually, the execution name reflected presentation settings, could you help with this also?

0 Kudos
holashh
Enthusiast
Enthusiast

Hi, I played little bit around multi-node plug-in I solved it, I hope that I solved it.

I connect my remove workflows as asynchronous workflows and now it is working, I will test it little more deeper and I hope I will solve it in standard way of workflows usage.

Otherwise again thanks for your snippet it is awesome! :smileycool:

KR

Jan

0 Kudos