FAITEUR
Contributor
Contributor

Cannot "Register vCenter Orchestrator as a vCenter Server extension" in Orchestrator 8.0.0

Hi all

the workflow "Register vCenter Orchestrator as a vCenter Server extension" does to work to register the orchestrator 8.0.0 extension on vCenter 6.7U3.

It fails with the error: "java.lang.IllegalArgumentException: cert parameter is required (Workflow:Register vCenter Orchestrator as a vCenter Server extension / Register extension (item1)#10198) "

The problem is correctly described in the Release Notes of the 8.0.0 as a "Known Issue".

Unfortunately no solution or workaround is provided.

I was wondering if such workaround exists, perhaps registering the extension by alternative methods.

Otherwise I guess I will be forced the customer to roll back to the previous version.

Thank you

8 Replies
iiliev
VMware Employee
VMware Employee

Hi,

There is a fix for this particular "cert parameter is required" error, in a form of a new build of vCenter plug-in.

The problem, however, is that this fix alone is not enough. Even with successful extension registration, you'll hit another issue on vRO 8 server side, which will break the download and deployment of the actual vCenter integration plug-in.

At the moment, I think there is still no solution / workaround for this issue.

0 Kudos
cloudyred
Enthusiast
Enthusiast

Is the issue with plugin install that the service in the container never seems to restart to pick up the new plugin? If so, the below worked on the Beta after you find your pod name with "kubectl -n prelude get pod |grep -v vco"

"kubectl -n prelude exec vco-app-8bf5f9ffd-tfxd7 -c vco-server-app -- /bin/toybox kill -s TERM 1"

-Red

manfriday
Enthusiast
Enthusiast

Where does one find the new vCenter plugin? I looked around and can't seem to locate it.

0 Kudos
iiliev
VMware Employee
VMware Employee

The new plug-in build is uploaded at https://communities.vmware.com/docs/DOC-32872

manfriday
Enthusiast
Enthusiast

Thanks! I saw that but the "vSphere for 6.5" bit threw me off the trail!

0 Kudos
JoeHFT
Contributor
Contributor

After upgrading the plugin to Version 6.5.0-15013492, I'm still receiving the error.  Is there something that needs to be done after upgrading the plugin?

0 Kudos
iiliev
VMware Employee
VMware Employee

After uploading the new plug-in, have you restarted the Kubernetes pod of vRO server?

0 Kudos
JoeHFT
Contributor
Contributor

I restarted the virtual appliance after the upgrade of the plugin. 

0 Kudos