keeptrying
Enthusiast
Enthusiast

Cannot Mount CD-ROM to a powered on VM

Jump to solution

I used 'Mount CD-ROM' workflow to mount an iso file to a powered on VM. But it returned error as following.

Found IDE controller (Key: 200) for busNumber 0

[2015-10-30 16:07:13.226] [I] Task 'ReconfigVM_Task' error: The attempted operation cannot be performed in the current state (Powered on). (Dynamic Script Module name : vim3WaitTaskEnd#20)

Am I missing something?

1 Solution

Accepted Solutions
keeptrying
Enthusiast
Enthusiast

I found the problem by myself.

Actually I deployed a  VM from vRA. And I found vRA will create a virtual cd drive with IDE(1:0).

But when dig into the workflow 'Mount CD-ROM', I found this workflow will only retrieve IDE Bus controller 0 !

As a result, of course I can not mount CD-ROM to a vRA VM !

And of course, I can customize the original workflow to fit my case, but I wish you (I mean, VMware) to offer a general one

which can fit most of cases.

Besides, 'Add CD-ROM' doesn't work either...

View solution in original post

2 Replies
keeptrying
Enthusiast
Enthusiast

I found the problem by myself.

Actually I deployed a  VM from vRA. And I found vRA will create a virtual cd drive with IDE(1:0).

But when dig into the workflow 'Mount CD-ROM', I found this workflow will only retrieve IDE Bus controller 0 !

As a result, of course I can not mount CD-ROM to a vRA VM !

And of course, I can customize the original workflow to fit my case, but I wish you (I mean, VMware) to offer a general one

which can fit most of cases.

Besides, 'Add CD-ROM' doesn't work either...

View solution in original post

RobertPr
Contributor
Contributor

Hi,

If youlike to fix the problem, change the

"VcVirtualIDEController"

to

"vcVirtualAHCIController"

in the Scriptable task: "Retrieve IDE Bus controller 0" in the Workflow "Mount CD-ROM"

So it should find the right controller with the SATA CDRom and mount the ISO to it.

0 Kudos