orian
Hot Shot
Hot Shot

Can't see all token

Hi,

I have installed for the first time VRA 7.5.

I noticed that I can see all the token of the workflows of all users - only my tokens.

Moreover, If I run from the vra a workflow (xaas blueprint), It appears in token list of the workflow, but when I try to run again the specific token I receive the following error box:

NullPointerException

I press continue and the token disappear from the list.

How, can I solve it?

In version 7.3 I was able to see all the tokens without any problem, the vra tokens and the users tokens which login directly to orchestrator.

Thanks!

0 Kudos
4 Replies
iiliev
VMware Employee
VMware Employee

Hi,

What kind of permissions does your user account have? If it is an admin, then you should see all workflow tokens; if a regular user, then only own workflow tokens.

For the NullPointerException - you try to run again it from vRO client, right? Could you check vRO logs (both server and client) for more information about the error, like Java stack traces, etc.?

0 Kudos
orian
Hot Shot
Hot Shot

I added on the top of library tree an active directory group with the following permissions:

View, Execute, Inspect, Edit, Admin

I'm in this group.

0 Kudos
iiliev
VMware Employee
VMware Employee

Workflow tokens are not normal inventory objects like eg. workflows. I don't think you can assign access rights to them in the inventory tree as you do with other inventory objects.

0 Kudos
orian
Hot Shot
Hot Shot

I finally created a new group in vsphere.local and added the relevant users.

I use this article:

https://www.vcoteam.info/articles/learn-vco/312-how-to-configure-vra-s-embedded-vro-to-allow-domain-...

0 Kudos