SteveCSchofield
Enthusiast
Enthusiast

Can't register vCenter in vRO 7.3 stand-alone appliance

Trying to setup a new vRO utility stand-alone appliance.  When I register vCenter,  I'm running the Add vCenter workflow.  Any ideas?  Here is the version of the VC pllugin. VC 6.5.0.5471688  the Vcenter is 6.5d

[2017-08-01 19:20:16.815] [E] Workflow:Add a vCenter Server instance / Register vCenter Server instance (item1) : ch.dunes.model.type.ConvertorException: Unable to convert object, 'vcenter1.ss.local' plugin exception reason : convertToResult() --> Finder 'VC:SdkConnection' : unexpected error 'ch.dunes.model.sdk.SDKFinderException: convertToResult() --> Finder 'VC:SdkConnection' : unable to invoke read method : 'instanceUuid''

[2017-08-01 19:20:16.835] [E] Workflow execution stack:

***

item: 'Add a vCenter Server instance/item1', state: 'failed', business state: 'null', exception: 'Unable to convert object, 'vcenter1.ss.local' plugin exception reason : convertToResult() --> Finder 'VC:SdkConnection' : unexpected error 'ch.dunes.model.sdk.SDKFinderException: convertToResult() --> Finder 'VC:SdkConnection' : unable to invoke read method : 'instanceUuid'''

workflow: 'Add a vCenter Server instance' (f246b7b5-fe89-4da5-a640-36ffc6874069)

|  'attribute': name=hostAndPort type=string value=vcenter1.ss.local:443

|  'attribute': name=errorCode type=string value=

|  'attribute': name=serviceUrls type=Array/string value=#{#string#vcenter1.ss.local:443#;#string#https://vcenter1.ss.local:443/pbm#;#string#https://vcenter1.ss.local:443/sms/sdk#}#

|  'attribute': name=certificateImportException type=string value=

|  'input': name=enabled type=boolean value=false

|  'input': name=host type=string value=vcenter1.ss.local

|  'input': name=port type=number value=443

|  'input': name=path type=string value=/sdk

|  'input': name=sessionPerUser type=boolean value=false

|  'input': name=userName type=string value=vUser@ss.local

|  'input': name=password type=SecureString value=__NULL__

|  'input': name=domain type=string value=

|  'input': name=ignoreCertificateWarnings type=boolean value=true

|  'input': name=httpPort type=number value=null

|  'input': name=pbmUrl type=string value=https://vcenter1.ss.local:443/pbm

|  'input': name=smsUrl type=string value=https://vcenter1.ss.local:443/sms/sdk

|  'output': name=newInstance type=VC:SdkConnection value=null

*** End of execution stack.

0 Kudos
11 Replies
SteveCSchofield
Enthusiast
Enthusiast

Why would I need to set Will you orchestrate this instance?

pastedImage_0.png

0 Kudos
CuttingRoomFloo
Contributor
Contributor

I would double-check you can ping the VC by fqdn from vRO (SSH session) as stupid as it sounds - It didn't seem like it couldn't connect from the error but without having watched the process it's always hard to tell as nix boxes generally don't auto-add to DNS. If it's a brand new 7.3 deployment I can't imagine you have plugin version issues (unless it's VC version - double-check compat matrix?), maybe make sure you can logon to VC web client using the account you're trying to connect with.

Regarding the 'will you orchestrate this' checkbox, my understanding is that you get additional right-click options in VC web client (e.g. right-click on vm shows: remove all snapshots wfl) if you select 'yes' here but I'm sure there must be other features available and I may be wildly wrong though can't find anything massively useful in the docs. I don't know if I ever tested with that set to 'no' tbh.

This post looks like similar issue but a long time ago and no real resolution I can see https://communities.vmware.com/thread/470416?start=15&tstart=0 If you've another VC spun up I would suggest trying to connect to it to see if error is same. A lot of the older posts talk about plugin version problems but I don't think that'll be the case here.

Also, be wary of which session type you use, per user is ok, as long as all required users have VC perms. If you set to per user session and say the svc account spinning up vm's doesn't have VC rights, you'll get issues (as it will use it's own creds to logon to VC). Additionally, it may not be immediately obvious in this case because when you look in vRO inventory, I believe it would use the account you've logged onto vRO as (which may well have correct VC perms) so it would 'look ok' to you. But that assumes the wfl to set it up completes in the first place, something to bear in mind when you get it connected.

0 Kudos
SteveCSchofield
Enthusiast
Enthusiast

good reminders to do basics.  dns good, no firewalls, time works.  I would rather not have this vRO appliance register within the vCenters.  This appliance will connect to multiple vCenters to perform operations on various machines.   That is what i'm trying to avoid.   I've tried both a limited user and full SSO / VC admin, same error.  I've opened a case with GSS to clarify this option.  Docs are light in trying to explain to my simple minded level Smiley Happy

0 Kudos
CuttingRoomFloo
Contributor
Contributor

Back to basics always best place to start for me Smiley Happy but have ben caught out enough times with the simple stuff that I get the generics sorted first and work up from there. In this case the error isn't massively helpful either. From what I can make out, that checkbox is optional so I'm not aware you are forced to select yes for this to work (else what's the point of the checkbox!). I'd be interested to see what GSS come back with if you wouldn't mind posting any resolution in due time. Always good to try and keep these things in the back of your head for later use.

I guess it's not a bad idea to start prodding the logs, most likely /var/log/vco/app-server/catalina.out as that may contain some nugget that the wfl logs aren't showing.

0 Kudos
iiliev
VMware Employee
VMware Employee

'Will you orchestrate this instance' option should be set to 'Yes' in most cases; otherwise your vCenter won't be available, eg. it won't show up in vRO inventory tree.

Actually, I'm not sure what exactly is the use case when you would want this to be set to 'No' Smiley Happy

CuttingRoomFloo
Contributor
Contributor

Interesting Smiley Happy I don't suppose there's any clarity in any (official/otherwise) docs about this? The docs I found basically lists the same text you see on the GUI form without any huge elaboration as to what the different choices would/could do. Seems like that shouldn't be an option really then on that form in that case? I never tried with it set to 'No' but mostly because it 'seemed like the right choice' to set it to 'Yes' more than anything else.

0 Kudos
SteveCSchofield
Enthusiast
Enthusiast

i'll let you know, when I run the workflow, this is the default option.  It doesn't seem to be too much documentation around this feature.

0 Kudos
daphnissov
Immortal
Immortal

I'd also be interested in knowing what precisely this option controls when running the workflow. I know it has nothing to do with registering the vRO extension with vCenter, so no danger there.

0 Kudos
iiliev
VMware Employee
VMware Employee

That's correct, to register a vCenter extension the user should use a different workflow - "Register vCenter Orchestrator as a vCenter Server extension".

What the workflow "Add a vCenter Server instance" does is to register a given vCenter endpoint in vRO, and setting this option "Will you orchestrate ..." to "No" simply marks this endpoint as disabled/inactive.

I'm pretty sure the error about instanceUuid will go away if you run the workflow with option "Will you orchestrate ..." set to "Yes". It is possible there is some issue/bug in the plug-in logic which tries to access vCenter endpoint and read instanceUuid property even if the registered endpoint is marked as disabled/inactive.

CuttingRoomFloo
Contributor
Contributor

Great info, thanks Ilian and I hope that sorts out your connection Steve. I noticed I had vRO wfl's available as right-click on my lab VC when I looked earlier but foolishly didn't try to click one, I just figured they were there because I'd registered it using the wfl in question. Now I try and run one of them it just takes me to the 'add a vRO server' page in VC client so my bad, sorry. At least another mistake to learn from and my list grows considerably Smiley Happy

0 Kudos
kdmahskey
Contributor
Contributor

I faced similar issue and found that it requires 'Will you orchestrate this instance' to be Yes, not sure the reason behind it.

Tags (1)
0 Kudos